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			After my first book with Packt Publishing (Unity for Architectural Visualization), I’m so glad this book became a collaborative work with Ruben. He brought in many different approaches to productivity and finishing the model and drawings. Although we couldn’t cover everything there is to say about Archicad, which would have taken at least two more books, I hope you will experience the same joy of learning about a software that makes so much sense, as it did to me in 1997, even before we started calling it BIM.
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			– Stefan Boeykens
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			I also have to give a shoutout to my co-writer and friend, Stefan. Thanks to Pieter Pauwels’ request for us to teach “something about Archicad” at the University of Ghent in a post-grad program on Building Information Management (BIM), we ended up bonding over our shared love for Graphisoft Archicad. And that, my friends, is the main reason we collaborated on this book. So, thanks for asking, Stefan, it has been a wonderful experience in which I have learned a lot from you (yet again)!

			Let’s not forget my partner in crime at studiov2, Pieter Vandewalle (no, not a relative!), for believing in me and allowing me to embark on this wonderful journey on behalf of our company.

			And last but not least, a massive thanks to all the Howest students in applied architecture and every studiov2 or KUBUS client who has challenged me over the last decade or so. Your questions, critiques, and (seemingly) impossible ideas related to Archicad have all contributed enormously to what I know about the software today and how I can share this knowledge with you in the most understandable way. Without your struggles, this book would for sure have been a lot thinner…

			– Ruben Van de Walle

			Foreword

			I have known Ruben van de Walle and Stefan Boeykens for many years now, as active, enthusiastic, and knowledgeable BIM practitioners, BIM educators, and overall digital content creators. Both Ruben and Stefan work primarily in Belgium and Europe and represent the Belgian community in 3D modeling, BIM processes and software, and digital architectural design practice at large.

			With this book, Ruben and Stefan present a practical and hands-on introduction and get-started book on the topic of Archicad, which is one of the major software tools for Building Information Modeling ( BIM ). BIM software such as Archicad allows modeling building designs into comprehensive 3D models that can be used to guide the design and engineering process, and to organize any construction site. As such, BIM in itself is an indispensable tool in the toolchain of the design and engineering specialist. Archicad in particular is known as the first commercially available BIM software in the world, and it is a tool of preference in architectural design offices primarily.

			This book is a very complete and all-inclusive book, which starts by explaining what Archicad is and how you can get started with this software. The book continues with the creation of a basic residential model, which is used as an example model throughout the book, to show example functionality. Full geometric modeling techniques are explained for all types of objects (stairs, beams, spaces, etc.). Furthermore, different types of drafting, linework, and hatching techniques are visually explained.

			The more advanced sections of this book deal with composite elements (floors, walls, layers, etc.), the use of the Renovation tool, the use of Complex Profiles, Detailing, and Viewpoints, as well as data extraction and visualization procedures (schedules). Full detail is given on the available publication workflows from the 3D BIM model to various outputs, such as PDF drawings, plots, hyper-models, and similar. Finally, the book explains in detail how to make compelling and functional visualizations in Archicad.

			As such, this book is your go-to resource for practical insights and hands-on tips and tricks that will boost your design workflow using Archicad.

			Dr. Ir.-Arch. Pieter Pauwels

			Associate Professor, Eindhoven University of Technology, Netherlands.

			Guest Professor, Ghent University, Belgium.
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			Preface

			A BIM Professional’s Guide to Learning Archicad is a comprehensive introduction to all that Archicad has to offer for the creation of 3D models, 2D document extracts, and related output. This book is not a click-by-click series of recipes but rather focuses on understanding why and how Archicad works the way it does by providing realistic examples for you to apply, and how you can apply this knowledge to improve your own BIM design workflow.

			The book introduces you gradually to Archicad tools, using ample examples, and mastering its complexity through several clear parts. This allows you to start a first project quickly, obtain useful skills in succeeding projects, and keep using the book at a later stage as a source for real insights into the software and useful expert tips and tricks. We’ll start with the basic modeling of construction elements and then gradually add roofs, stairs, and objects to the project. We’ll then dive into basic drafting and 2D views for creating 2D output, and explain how to use attributes and more advanced modeling tools for designing curtain walls and sites. You’ll also learn how to extract and visualize your data and how to automate the process of publishing your extracts and 2D documents into a variety of output formats.

			By the end of the book, you will have a profound understanding of Archicad and how to implement it efficiently in your own architectural projects, and how BIM can improve your overall design workflow.

			Who this book is for

			The book is for architectural designers, engineers, residential designers, BIM professionals, and anyone working in construction, manufacturing, or similar fields. Whether you’re an absolute beginner or a professional looking to upgrade your architectural or engineering design or urban planning skills, you’ll find this book useful.

			What this book covers

			Chapter 1, What Is Archicad and How Can You Learn It?, introduces Archicad and its developer, Graphisoft, with a short overview of its history, from the early 1980s. We also explain license types and what to expect from our approach to learning about the software.

			Chapter 2, Getting Started with Archicad, covers the first steps with the software, introducing the interface, the major concepts and interaction methods, and the onscreen feedback and data entry you will encounter. We end with starting and saving our first project file, ready to start modeling in the next chapter.

			Chapter 3, Building a Basic Residential Model – Modeling the Construction Elements, finally introduces modeling inside Archicad, by creating a small house step by step. This involves learning how to navigate in 2D and 3D and shows you how to model accurately. We will start with walls and slabs, but the main interactions apply to many other types of elements too.

			Chapter 4, Building a Basic Residential Model – Adding Roofs, Zones, Beams, and Columns, continues the basic model by introducing more construction elements that make up the core shell and structure of our project, but also its spatial content, using zones.

			Chapter 5, Building a Basic Residential Model – Modeling Openings, Stairs, and Objects, closes our first three chapters on modeling, with parametric objects such as doors and windows, and versatile system tools, such as stairs and curtain walls. We also tell you how to create a freeform shape, to create basically any object you can imagine.

			Chapter 6, Basic Drafting and 2D Views, uses the 3D model to derive 2D views, which can be enhanced with 2D drafting methods. We introduce different attributes that control how lines and fills look.

			Chapter 7, Adding Annotations and Creating 2D Output, closes the first part of the book, by adding 2D annotations onto the different views and preparing the final output documents, ready to be printed or shared as PDF.

			With this chapter, we end the first part by creating a basic residential model and using it to extract drawings, ready to be printed or digitally shared.

			Chapter 8, Using Advanced Modeling Tools for Developed Design, expands the model with more advanced modeling tools and techniques and further refinement of the elements, including their composite structure and how Archicad creates connections between elements.

			Chapter 9, Using Advanced System Tools for Designing Stairs and Curtain Walls, returns to the stairs and curtain walls for more refinement and complete editing in detail.

			Chapter 10, Using the Mesh Tool and Wizards to Finalize a Design, explains how to model our terrain and introduces two wizards to generate a complete truss and roof structure, starting from basic geometry.

			Chapter 11, Using Advanced Attributes and the Renovation Tool for a Wider Design Range, explains how to control element sections with parametric, complex profiles and also introduces a few attributes to indicate the renovation status of objects, their structural function, and whether they are positioned as part of the building envelope or shell.

			Chapter 12, 2D Construction Drawings and 3D Views with Linked Annotations, dives deep into the Archicad attributes that help control the look and feel of lines, fills, and other attributes in more detail. We will also return to our sections to control how they can dramatically change the display of the model. Finally, we will learn a few methods to organize construction detailing and how to display building fragments, to help you communicate the intent of the design.

			Chapter 13, Data Extraction and Visualization, leverages the model to extract information into tabular schedules and to override the graphics of elements, to create alternative, thematic views, all model-based.

			Chapter 14, Automating the Publication of BIM Extracts, elaborates on the publication workflow, from the initial viewpoint to defining views, collecting them in layouts, and finally, generating all the output as a single publisher set. This unlocks the power of being able to update the model and have all related documents and output updated automatically. Let the system work for you!

			Chapter 15, The Various Visualization Techniques in Archicad, completes the book by generating different compelling and interesting visual output, including photorealistic rendering and how to bring the model into an interactive application.

			The Appendix section gives a summary of what the book covered, but also a few pointers to additional features and options that could not be covered in the book, but which can help you to grow to the next level of Archicad proficiency.

			To get the most out of this book

			No prior knowledge of Archicad is necessary. You are expected to have construction knowledge (architectural design), and a basic understanding of 2D CAD drafting is recommended. The book is based on the international version of the software and uses metric units. The hardware requirements should be fine for a basic project (single-family or residential), but larger projects will need more RAM and higher-end CPUs and GPUs.
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			While model files are provided from the download link in the next section, we advise you to go through all steps one by one to familiarize yourself with input and the software interaction. This experience is essential to become productive in your own projects. When you get stuck, you can take a look at the provided models to get a clean start or compare them with your own model.

			You can follow most of the book using versions that are up to 3 or 4 years old. Earlier versions may lack some of the current features, and the interface has also been updated considerably since older versions. If you don’t have access to the full version of the software, a trial or educational version works just fine. Contact a local reseller for further support.

			Download the example model files

			You can download the example model files for this book from GitHub at https://github.com/PacktPublishing/A-BIM-Professionals-Guide-to-Learning-Archicad. If there’s an update to the models, it will be updated in the GitHub repository.

			We also have other code bundles from our rich catalog of books and videos available at https://github.com/PacktPublishing/. Check them out!

			Download the color images

			We also provide a PDF file that has color images of the screenshots and diagrams used in this book. You can download it here: https://packt.link/JIoo1

			Conventions used

			There are a number of text conventions used throughout this book.

			Code in text: Used where a user needs to enter a value or text string in the user interface. You can use any other value if you want, but if you want to follow the examples, please use the provided text entry. Here is an example: “We’ll keep it simple and set our layout number in Custom ID to 01 and Layout Name to Quick Layout.”

			Keywords: Used to introduce or emphasize new concepts, typically the first time they are encountered. These are mostly terms for concepts and features that the software introduces. Here is an example: “As an alternative, we sometimes attach a drawing to an Independent Worksheet and use Trace and Reference to display it in a section or on a ground floor plan, which gives more flexibility.”

			Bold text: Indicates important words or any term you see onscreen, in a dialog box, or anywhere else in the user interface. Here is an example: “So, in this case, the A3 Landscape master layout.”

			Italics: Indicates emphasis on certain words, product names, or brands and also menu entries and keyboard shortcuts. It is also used to indicate references to figures or other chapters. Here are two examples: “This may seem quite a lot, but we will return to the published workflow in Chapter 14.”

			Tips or important notes

			Appear like this.

			Get in touch

			Feedback from our readers is always welcome.

			General feedback: If you have questions about any aspect of this book, email us at customercare@packtpub.com and mention the book title in the subject of your message.

			Errata: Although we have taken every care to ensure the accuracy of our content, mistakes do happen. If you have found a mistake in this book, we would be grateful if you would report this to us. Please visit www.packtpub.com/support/errata and fill in the form.

			Piracy: If you come across any illegal copies of our works in any form on the internet, we would be grateful if you would provide us with the location address or website name. Please contact us at copyright@packtpub.com with a link to the material.

			If you are interested in becoming an author: If there is a topic that you have expertise in and you are interested in either writing or contributing to a book, please visit authors.packtpub.com.

			Share Your Thoughts

			Once you’ve read A BIM Professional’s Guide to Learning Archicad, we’d love to hear your thoughts! Please click here to go straight to the Amazon review page for this book and share your feedback.

			Your review is important to us and the tech community and will help us make sure we’re delivering excellent quality content.

			Download a free PDF copy of this book

			Thanks for purchasing this book!

			Do you like to read on the go but are unable to carry your print books everywhere?

			Is your eBook purchase not compatible with the device of your choice?

			Don’t worry, now with every Packt book you get a DRM-free PDF version of that book at no cost.

			Read anywhere, any place, on any device. Search, copy, and paste code from your favorite technical books directly into your application. 

			The perks don’t stop there, you can get exclusive access to discounts, newsletters, and great free content in your inbox daily

			Follow these simple steps to get the benefits:

			
					Scan the QR code or visit the link below
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			https://packt.link/free-ebook/9781803246574

			
					Submit your proof of purchase

					That’s it! We’ll send your free PDF and other benefits to your email directly

			

		

	


		
			Part 1: Getting Started with Archicad – Project Setup and Essential Modeling Tools for Your First Residential Project

			The objective of this part is to familiarize you with Archicad, the BIM concepts used in the software, the user interface, and the essential modeling tools that are commonly used when designing a small residential project. Throughout this part, you will learn how to use a variety of tools by creating a first project step by step. At the end of this first part, you will be able to model a basic residential project, at a preliminary stage, including using simple drafting tools and preparing printed output.

			This section comprises the following chapters:

			
					Chapter 1, What Is Archicad and How Can You Learn About It?

					Chapter 2, Getting Started with Archicad

					Chapter 3, Building a Basic Residential Model – Modeling the Construction Elements

					Chapter 4, Building a Basic Residential Model – Adding Roofs, Zones, Beams, and Columns

					Chapter 5, Building a Basic Residential Model – Modeling Openings, Stairs, and Objects

					Chapter 6, Basic Drafting and 2D Views

					Chapter 7, Adding Annotations and Creating 2D Output

			

		

	


		
			1

			What Is Archicad and How Can You Learn It?

			In this first chapter, we will introduce you to the book and its main content. We will get some background information about the Archicad software and its development and how it is installed and licensed. We will also learn about the main objectives and approach of this book, setting expectations right from the start. This is not meant to be a cookbook with step-by-step recipes showing buttons to click but, instead, aims to give you a proper understanding of how the software fits into a professional workflow.

			The main topics we’ll cover in this chapter are as follows:

			
					An introduction to Archicad

					A brief history of Archicad

					Setting up Archicad

					Licensing

					The approach of the book

			

			By the end of this chapter, you will know what Archicad is, how you can install it, and what license types exist. You will also have a clear understanding of the approach toward learning Archicad in this book.

			Introducing BIM and Archicad

			This book introduces Graphisoft® Archicad®, advanced software for architects and other designers, which follows a methodology that is known as Building Information Modeling (BIM). It is an approach to developing digital models for buildings or other constructions that forms the basis for all kinds of documents and reports that are typically created by architects, such as drawings, renderings, and schedules, among many others.

			BIM is gaining worldwide popularity and is quickly becoming the best practice in construction projects of all sizes. It helps you to better manage information and all related graphical documents, while at the same time avoiding mistakes, inconsistencies, or inefficient workflows.

			You will use the Archicad software as one of the main tools in your BIM toolkit, not only to model and draft but also to develop a design, help you understand the spatial layout and qualities of your concepts, and help you in collaboration with other project partners, such as your client, other designers or engineers, the contractor, and manufacturers. The models you develop will become one of the main sources of information for a project, and ensuring they can be created efficiently is essential to become productive in a project where BIM is applied.

			While we don’t expect you to already have experience with BIM, it would be helpful if you have an overall understanding of the construction process and, possibly, some experience with making drawings using general CAD software, such as AutoCAD®.

			The objective of using software such as Archicad is not simply to create 2D drawings but to really develop a model, with 3D geometry and embedded information, that allows drawings to still be extracted from it. This is also what we will cover in this book.

			About Graphisoft and Archicad – a short history

			Graphisoft was founded in 1982 by Gábor Bojár and his business partner Ulrich Zimmer, with Archicad being the first program they developed, specifically for solving coordination issues in a project by the Hungarian government to construct a new nuclear power plant. More specifically, the coordination of the complex 3D geometry of the building’s structure and its piping didn’t go as well as it should have done.

			Graphisoft was able to develop its software in time to win the bid for this project and used the earnings to further develop the company. It’s worth mentioning that Gábor Bojár and Steve Jobs met in 1984 at a trade show in Germany. Jobs saw opportunities in the software, to prove what his machines were capable of, and Bojár was at the time looking for good hardware to continue development. We should not forget that in the 1980s, the Iron Curtain was still in place, and allegedly, four Apple® Macintosh® machines were smuggled into Hungary, and Graphisoft was able to further develop Archicad. Although Apple’s Lisa was a commercial failure, reviews of the Archicad software at the Hannover Fair that year were excellent, and Bojár and his team managed to survive the next few years. Macintosh machines improved and became a success in their own right, along with Graphisoft steadily growing as a company and Archicad being developed into a more mature product.

			The good relationship between the founders of Graphisoft and Apple is worth mentioning because it probably explains to a large extent their somewhat shared vision of how software should work for a user. Like Steve Jobs, Gábor Bojár believes in the benefits of “intuitive” software, a compact and “logical” user interface, and a focus on the user experience, rather than on the software itself and all of its marvelous capabilities.

			It also explains why this Hungarian company was the first to unveil a statue of the late Steve Jobs – it was a commission by Bojár for his old friend, about whom he expressed that Graphisoft might not be around today if it weren’t for him.

			Since 1993, Archicad has also been available for Microsoft® Windows®. The software has gradually expanded, including more advanced modeling and collaboration tools, high performance using multi-threading and hardware acceleration, and going beyond architecture with its structural and mechanical toolsets. One of its strong points, since the beginning, has been its Geometric Description Language (GDL), which is at the core of the parametric objects in the Archicad library, presenting highly efficient and flexible objects. Another point of note is the BIMcloud module, which allows multiple users to connect to the same Archicad model (stored in the cloud) and make (coordinated) edits simultaneously.

			The Graphisoft Help Center (https://community.graphisoft.com) contains an overview of all versions of the software, giving you an insight into the evolution of it and the inclusion of major features and changes (https://community.graphisoft.com/t5/Let-s-get-started/Archicad-versions/ta-p/304207).

			In 2007, Graphisoft was acquired by the German Nemetschek™ group, where it now is part of a large group, including the likes of Vectorworks®, Allplan®, Scia® Engineer®, Solibri®, and Cinema 4D®, all mainly targeted at 3D modeling or construction.

			Archicad is currently one of the major BIM-authoring software tools, alongside competitors such as Autodesk® Revit®, Vectorworks, and Allplan. It has a good reputation for being user-friendly and supporting a wide variety of 2D and 3D file formats for collaboration with others. It is worth mentioning that Graphisoft is a strong supporter of the openBIM approach by supporting the exchange of data across BIM software, using open standards and related file formats.

			Installing Archicad

			While we assume that installing software should not be a problem in general, there are a few aspects of the Archicad installation that should be considered.

			Platform requirements

			Archicad is multi-platform software, which can be used on Microsoft Windows and Apple macOS®. The exact requirements of the software are indicated on the Graphisoft website (https://graphisoft.com/resources-and-support/system-requirements), so for fully up-to-date specifications, you should check there first.

			In general, Archicad supports the current iterations of both operating systems. However, when a major update of the platform is released, it is recommended to consult the Graphisoft site prior to upgrading. macOS users especially have encountered issues by jumping too soon when Apple releases an upgrade to its operating system, which is about every year around autumn. There are often large changes that impact graphically demanding software such as Archicad. Conversely, Graphisoft always tries to benefit as much as possible from software and hardware improvements, and not only fully takes advantage of multiple cores but also, more recently, embraced Apple’s M1® chipset.

			In general, there are a few requirements that are of primary importance, which you can see in the following list. Archicad is demanding software, both in terms of storage and in terms of system requirements:

			
					Having a fast CPU is but one of the requirements. Archicad makes heavy use of multi-threading, so having a multi-core processor (four cores or more) is recommended for smooth operation. If your system is still 32-bit, it won’t work, but in that case, your computer is too old to run such intensive applications anyway.

					You need plenty of RAM available, both in the main memory and the video memory. As the software is graphics-intensive, if at all possible, use a system with a dedicated GPU or graphics adapter. This is often difficult with office laptops, which tend to have a limited GPU. This may limit navigation and 3D display. CAD and 3D software ideally would run on a workstation-class desktop or laptop. Some users also get good performance with gaming-oriented systems, since they tend to have powerful graphic cards.

					It is highly recommended to use solid-state drives (SSDs) for the fast loading of projects and library files with sufficient storage space. The installer is almost 2 GB, and when installed, the software uses several GB of storage. This is largely due to the object libraries, including the default plugins and textures.

					Depending on the size of the projects you develop, you also have to understand that Archicad projects tend to generate large files. Smaller projects may need less than 100 MB, but larger and more complex projects can go above 1 GB for a single project file.

					As with most professional applications, having a large monitor (or two or three) also helps with the setup of your workspace. Using a full HD or 4K screen resolution is recommended. Professional users typically select a dual-screen setup or a very large widescreen to get the best working environment, but if needed, you can use the software on a laptop and bring the whole authoring environment with you, on-site or to a client.

					Archicad is mainly controlled with a mouse and keyboard, so touchscreens do not provide any advantage, but an advanced 3D mouse can be beneficial.

			

			And finally, as discussed in the following section, Archicad is commercial software that uses a protection system. This can be in the form of a hardware key, requiring a USB port, or a software key, in combination with your personal Graphisoft ID.

			Older versions of the software

			It is still possible to use older versions of the software, which remain available for download from the Graphisoft website. While your license entitles you to use any older version of the software, the actual version that will work depends on the operating system you use. Older versions are not further developed nor supported and may not work in current versions of your operating system.

			For people using an older computer with an older operating system, this is sometimes a solution, as they can run a previous Archicad version, with lower hardware requirements.

			Another reason to use older versions may be related to the project – when construction projects last several years, it is not always acceptable or advisable to upgrade software tools throughout the project, unless this is agreed upon with other people you collaborate with. In that case, offices sometimes tend to continue a project using the software version that was used when setting up the first models. In other cases, upgrading to a newer release has to be planned carefully to not disturb agreed workflows. It is not uncommon to wait a few months after a new release before upgrading.

			A final reason for keeping the libraries of older installations available is related to the project and library management – although there is the option to save a project in an archive format (which contains any Library Part used in the project), occasionally some Library Parts are not correctly migrated or are even completely missing. In such a scenario, still having copies of older versions of the Library Container Files can be a lifesaver. You do not even need to have the software fully installed for this, and in any version of the software, Migration Libraries are included, but this does not always solve every migration issue that could arise...

			By now, you have learned how Archicad came into existence, what it is meant for, and which hardware and software is required to use Archicad. Next, we will learn what license types are available and what type and version of Archicad is required for this book.

			Licensing

			Archicad is developed and marketed as commercial software for professional users. As with most advanced and specialized software, this requires a user to select one of the different license models, depending on their activity.

			License types

			The primary license model is a full commercial license. The user gets access to the full software using either a hardware lock (dongle) or a software key, to prevent abuse of the license or sharing a license. Graphisoft still offers this as a perpetual license, which never expires, but it also advises users to get a maintenance contract, which adds support and all future Archicad updates at a yearly cost.

			For people not requiring the full feature set of the commercial license, a cutdown STAR(T) edition is also available. This comes at a lower license cost and is primarily targeted at smaller offices, where collaboration and integration features are not required.

			Alternatively, a pay-per-use license is also available when you need one or more additional licenses for a limited time. This can also be of interest to users who use the software just occasionally, although you may need a full commercial license to qualify for a pay-per-use license. It should also be noted that this license type may not be available in your market.

			If you intend to develop add-ins for Archicad, you can opt for a developer license, which is valid for 1 year and gives you full access to Archicad and support from the development team. Note that such a license cannot be used for commercial purposes, such as architectural or engineering services.

			More recently, Graphisoft and its resellers have started to provide a subscription license, which, as the name implies, gives you access to the software and all updates for a fixed, monthly, or yearly fee.

			For actual license pricing, you are advised to contact a local reseller, as there may be differences between not only markets but also the offered services and additional benefits, such as localized templates or libraries.

			While you are still discovering the software, you can request a temporary trial license, which gives you full access to the software, including saving and printing, but with a fixed expiration date and locked to the computer where the trial was activated. If you decide after the trial to continue with a commercial license, Graphisoft can assist you with upgrading the files saved during the trial.

			Finally, if you are a student or teacher, you have free access to the educational license. This has no functional limitations, but the output of documents and exports will be watermarked to avoid commercial use. You can access educational licenses at https://myarchicad.graphisoft.com. You can start immediately with a temporary 30-day license, which is extended for 1 year after approval by the regional reseller, upon proof of educational enrolment. This offer can be extended as long as you still comply with the educational requirements.
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			Figure 1.1: An example of the educational watermark in the Viewport

			In all cases, you must activate the software using a (free) Graphisoft ID to ensure you are entitled to the license you use. This Graphisoft ID also gives you access to multiple Graphisoft products and services, such as the following:

			
					Graphisoft BIMcloud: This server technology lets you collaborate with several team members on one central model, using Teamwork technology. It is available in three license types, of which BIMcloud Basic is included with any commercial license.

					Graphisoft Learn: This online training platform can be a great accompaniment to this book. Tutorial videos are offered on a variety of topics, some of which are discounted or even free for certain license types.

					BIMx and BIMx Model Transfer: BIMx is available as a separate mobile app and as a desktop application (the free version is included with every Archicad installation – you can easily upgrade to the paid BIMx Pro for some extra features). The app combines fluent 3D navigation and visualization with interactive hyperlinks to 2D-derived documentation. This transfers a model and a full set of (chosen) data from your modeling tool to your mobile presentation device, making it well suited for client meetings and visits to a construction site.

					https://bimcomponents.com: Here, you can find additional Library Parts for Archicad, checked and approved by Graphisoft.

					Graphisoft Community: On these forums, Graphisoft employees, Archicad gurus, and BIM specialists discuss a variety of topics. They are a great place to ask a simple technical question, propose an improvement to the software, lose yourself in a discussion on a GDL parameter, or just make new friends.

			

			For more on these resources and links, please refer to the Appendix.

			Migrating between license types

			Exchanging projects between Archicad versions with different license types is somewhat limited. You can perfectly exchange Archicad projects created with a full commercial license, a subscription license, or a pay-per-use license. A full version can open projects created with any STAR(T) edition, but that edition does not allow you to open files other than the ones created with this license type.

			Should you decide to acquire a fully licensed version of Archicad, after your trial period has ended, you will be able to continue to work on the projects created within this trial version of the software, as long as you upgrade the trial and did not uninstall it.

			Projects created with an educational license can be opened in a fully licensed version of Archicad, but Archicad will (temporarily) switch to Educational Mode and show the educational watermark. Opening a file made with a commercial version in an educationally licensed version of Archicad will transform the file irreversibly to an educational version. Copying from educational projects to commercial ones is also prevented.

			Localized versions

			Archicad is developed for a worldwide audience. However, to cater to the large difference in languages, terminology, and construction methods, it is distributed in different localized versions. This not only defines the language of the user interface but also gives Graphisoft, or the local reseller, the opportunity to adapt the content that is installed with the software.

			There is one main version, which is called International (INT). This uses the English language and contains the default Archicad library and template.

			Various countries or regions have a localized version available, and they can be discovered on the Archicad website. Be sure to select the region that is associated with your Graphisoft ID. Check with your reseller to see which of the more than 20 localized versions is available to you and whether your license gives you access to different localized versions. If your region is not available, you can use the INT version instead.

			Requirements for this book

			For this book, it doesn’t really matter which license you have access to. Considering the depth of the subject, a time-limited trial version may not last long enough to work through the whole book, but you can use any commercial or educational version without issue.

			The book is written primarily using version 26 of the software, but as the software is quite mature, most of the content still applies to previous versions. However, we don’t recommend trying to follow along with versions older than 3 or 4 years, since the interface and the features have evolved considerably.

			The approach in this book

			This book is written with the assumption that you are starting from scratch, with only minor experience in architectural drafting and general IT skills. We don’t want to bother you with countless trivial details about software in general but, rather, focus on Archicad and where it can differ from other systems.

			There is a logical order in the chapters, starting from the humble beginnings in Part 1, where you are introduced to the software and learn just enough so you can create a basic house, sufficiently developed for the preliminary design. This will help you at the start of a project.

			In Part 2, we will increase the level to an intermediate stage, where we will learn about many of the tools we haven’t covered yet and dive deeper into the ones we already learned about. You may start to experience the sheer depth of Archicad and how flexible it is. It must be, because it is used worldwide, in a variety of countries with vastly different construction methods and materials.

			After these two parts, you should be able to set up and complete your first few projects, at least if you are willing to practice and dive deeper into the documentation or the online communities when some details need more explanation.

			While there is much more to Archicad, we had to leave out some of the more advanced and complex methods in it. The Appendix gives a brief overview of many of the additional features Archicad has to offer, such as collaborative BIM workflows, both with other Archicad users and with people running other software, by using openBIM methods and formats. There are also engineering-focused structural and MEP modules (used for modeling Mechanical, Electrical and Plumbing elements). To cover all of this, we would probably need one or two additional books.

			What to expect as a reader

			This is not a cookbook of point-and-click recipes. We want to explain the different tools, but with a strong focus on methodology and the reasoning behind the different choices that are made. The aim is for you to understand what you are doing, rather than memorizing tricks that only work well in a fixed scenario.

			Every project is different, and the many tools in Archicad can all be used in a variety of ways. It is a flexible system, but with that comes certain complexity. So, we are not able to cover every little detail, setting, or configuration. After all, the whole manual, which hasn’t been a printed book for a long time, is over 4,000 pages! It is digitally available from within the software, and properly searchable and indexed.

			Note

			The Archicad reference guide is the full catalog of every tool and setting. This learning book is a guideline for using the software efficiently. They are complementary.

			If you need more resources, the Appendix will give you more references to the various communities and other channels of information and knowledge related to Archicad.

			Our experience, as users and teachers of Archicad, is that starting with core training (such as working through this book) before you properly get used to finding your way around the software and have a good grasp on the terminology and tools at your disposal works best. From that point on, it becomes much easier to look for answers, to search through the documentation, and, in general, to solve your problems yourself.

			This workflow approach could have gone in different directions; one approach is going through all the tools, one by one, to ensure that you don’t miss a spot. That is not the approach we like to bring you, as a reader, since it takes a long time and is, frankly, very boring.

			The opposite approach would be to take a single project from start to finish. There are many arguments for this, so we will follow this approach to a certain extent. We will move mostly in chronological order of what you would encounter in a project, but there are a couple of catches:

			
					Developing a full project works differently the first time around! Once you have completed a few projects, you know where you will end and, thus, can better prepare for it. You cannot do this when you first start. So, we must jump into a project with no assumptions about what we already know or understand. We will introduce tools that fit at that point in the process, but we may not cover them completely to not overwhelm you with details that don’t matter initially.

					We haven’t come across a single project, yet, that requires every tool in Archicad. Or, to put it another way, the architects in us are not too keen on arbitrary designs that don’t have any architectural value and are just a mixed bag of all the tools you may encounter. They tend to be more like Frankenstein designs.

			

			So, we opted instead to work with a few basic reference projects to guide you through the process and introduce smaller, singular examples if needed, or if the tool that is discussed requires it.

			Version and units in this book

			There is another choice we had to make in this book. To cater to the widest possible audience, we don’t use one of the many splendid, localized versions of the software or one of the extensive specialized libraries available. We stick with the basic INT version and its default library and template. It was created by Graphisoft to be globally applicable for many project types. Since every localized version is derived from it, you could state that this version is at the core of every other version.

			We understand your personal situation may differ from that, and you are strongly advised to adopt first and foremost the localized version and related templates and libraries for your language or region. This is especially advisable when your local reseller has prepared this generic template to better cater to local building practices, regulations, documentation habits, or anything else that Graphisoft could not prepare for you.

			Another choice here is to stick with the metric system throughout the book, which is valid for all but a few countries in the world. We assume that those who prefer to work in imperial units can adapt easily, since the display of units is but a setting in the software. Since you will work at full scale, Archicad can display units as you see fit, using feet and inches or, rather, meters and their derived units.

			A final note should be made about the screenshots included in this book. These are taken from projects opened with Archicad 25 or 26 INT, running on macOS. There are only a few differences with Archicad running on Windows, which will be mentioned throughout the book where applicable. Also, both the Mac and Windows variants of shortcut keys will be mentioned (e.g., Cmd + D/Ctrl + D).

			So, with these explanations and disclaimers out of the way, we are ready to start our journey into Archicad.

			Summary

			In this chapter, we introduced you to Graphisoft Archicad, its variety of license types, and how you can select the applicable one for you. In the next chapter, we will learn a little bit more about the installation and explore the user interface of the software before we set up our first Archicad project!

			Further reading

			If you are interested in the history of Graphisoft and Archicad, here are some interesting links we based our summary on:

			
					https://hbr.org/1991/01/micro-capitalism-eastern-europes-computer-future

					https://www.cultofmac.com/428277/software-firm-commemorates-golden-steve-jobs-moment-with-bronze-statue/

					https://graphisoft.com/it/press-releases/jobsstatueunveiled
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			Getting Started with Archicad

			When getting started with complex software such as Archicad, we must learn about its interface and how the software can be configured. First, we will be introduced to the way Archicad provides onscreen feedback. Then, we will get an overview of what gets installed with the software and why it is taking up so much room on your computer. And finally, we will start our first project and set it up properly.

			Here are the topics covered in this chapter:

			
					Understanding the Archicad installation

					Understanding the Archicad user interface (UI)

					Setting up your first Archicad project

			

			Technical requirements

			For this chapter, you will need a working copy of Archicad—ideally, version 26 or 25. Any of the license options mentioned in Chapter 1, are fine. Choose the version that suits you best through the Graphisoft website (https://graphisoft.com/try-archicad).

			Understanding the Archicad installation

			Let’s look at what gets installed onto your computer, what this all contains, and what the impact of a localized version on all of this could be.

			What is installed?

			The Archicad installation takes up quite some space... not only for the software and its components but also because of the libraries with content that get installed. The installation process is straightforward but may take a while. Meanwhile, you are greeted with a few nice pictures of projects designed by international Archicad users.

			After the installation wizard finishes, you are asked to reboot your computer. This is caused by the drivers for the software protection system and the filesystem integration. Some security messages may also pop up to give Archicad the required permissions for the filesystem.

			All in all, the installations on macOS and Windows are practically identical. They have the same folder structure and contain the same library files. Only the executables (the main programs) and the add-ons are platform specific.

			Apart from minor differences between platforms, such as the availability of fonts or some platform-specific features, it should not pose any issue to switch between platforms or to collaborate with others.

			Other languages or versions

			If you use a localized version of Archicad in a different language, some of the folders may have a translated name, but their function remains the same.

			For example, when we install the local Key Member edition for Belgium or the Netherlands, it gets installed over the current INT version and adds translated default libraries and some additional libraries, plugins, and resources.

			By way of example, if you have a French, German, or other language edition of Archicad, the folder names and libraries are fully translated, and you end up with a separate installation folder for Archicad instead of the INT version. You can have multiple versions of Archicad installed at the same time: either different releases (24, 25, and 26) or languages (INT, USA, GER, NED...).

			Now that we have a clear understanding of what is installed, it is time to fire up the Archicad application for the first time and explore its UI!

			Understanding the Archicad UI

			When you open Archicad for the first time, you are presented with the default interface layout or work environment:
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			Figure 2.1: Default Archicad 26 INT work environment with the main UI components

			Depending on your installed version of Archicad, things may look a little (or a lot) different, but it always works the same way.

			Getting to know the main UI components

			As with most software, Archicad has a main menu (or menu bar) that sits at the top of the screen on macOS and above the toolbars on Windows. The menu is organized logically from left to right:

			
					The File menu gives access to starting new projects, opening, closing, and saving files, and the menus for managing libraries, reference files, and interoperability tools.

					The Edit menu focuses on elements in the model, including commands for moving and transformations, alongside the typical Undo/Redo and Copy/Cut/Paste commands.

					The View menu groups many commands related to how Archicad displays the model, with a variety of options that can be toggled, such as the display of the grid, line thickness, and onscreen options to help when modeling.

					The Design menu helps you manage the Virtual Building, including accessing all modeling commands, extensions for design analysis, and the management of model information.

					Document focuses on the annotation commands, such as text, labels, and dimensions. It also gives you access to the variety of views Archicad can create from your model, including renderings and schedules.

					Options is where you manage attributes, properties, and classifications. We’ll return to attributes in detail later in the book.

					Teamwork groups the BIMcloud collaboration features, to share and synchronize models with other co-workers.

					Window allows you to show or hide all UI toolbars, panels, palettes, and other windows that define the Archicad UI.

					Finally, the Help menu, the last one, gives access to the Archicad documentation, including online and offline resources and license information, and checks for updates to the software.

			

			Depending on your Archicad installation, additional menus may also show up (between Window and Help), but we won’t discuss them here.

			Toolbars and palettes

			Around the main graphical window, we get a series of docked toolbars and palettes.

			Toolbars contain commands you can click, whereas palettes contain multiple widgets, such as buttons, lists, checkboxes, or other UI elements:

			
					Viewport—The largest area on your screen, meant for modeling, drafting, drawing… in other words: creating your design.

					Toolbar—By default at the top, this contains various non-modeling tools that are frequently needed but can also be accessed through the menus at the top. Some of the buttons in the toolbar can have underlying drop-down menus, indicated by a downward-pointing small arrow.

					Tool box—By default on the left, contains all the modeling tools, grouped in a logical way. From top to bottom, we have the following:	Selection tools (Arrow tool and Marquee)
	Design tools (Wall, Door, Window, Column, Zone, and Mesh tools)
	Document tools (Dimension, Spot Dimension, Figure, and Drawing tools)
	Viewpoint tools (Section, Elevation, Interior Elevation, Detail, Worksheet, and Camera tool)



					Info Box—By default at the top, beneath the toolbar, this displays (condensed) settings for the currently selected command or tool. It contains a selection of the complete collection of settings that can be found by accessing Element (Default or Selection) Settings, which is explained in Chapter 3, and further.

					Navigator—By default at the right, this contains the structure of your model and its different views, sheets, layouts, and publisher sets. This “table of contents” structures everything you create in a project and keeps track of how you want to view the model, create layouts, and publish all the content.

					Tab Bar—By default at the top of the Viewport, this shows all open views or viewpoints and lets you easily switch between active views or viewpoints without scrolling through the Navigator. Open tabs are given priority when the model is being updated in the background and when a change in the model is being applied.

					Quick Options Bar—At the bottom of the screen, below the Viewport, this shows the current display settings of the active tab. These settings can be used to quickly change the displayed content and the appearance of the currently shown Viewport, using the pop-up lists showing the available options. How a certain combination of settings is saved into a view is discussed later.

			

			Toolbars and palettes can be docked so that they stick to the sides of the Archicad window, or they can float where you want. You can also close them if you don’t need them. To reopen toolbars and palettes, go to the Window menu, and look for the desired toolbar or palette.

			As with most software, Archicad also has countless dialogs, which can be opened from menus, from commands on a toolbar, or from palettes. In contrast with a palette, a dialog is modal, which means that it demands your full attention: the rest of the interface is blocked until you close the dialog, either by accepting its input or by canceling it.

			Understanding work environments

			The whole UI layout can be configured in detail and stored in a so-called Work Environment. You can store and recall work environments at any time. With your Archicad installation, a few preset environments are included, allowing you to switch between them.

			A work environment profile is used to store countless settings and configurations, so you can apply this when you need it. We apply the default Architectural Profile from the menu (Options > Work Environment > Apply Profile > Architectural Profile).

			When you apply the Structural Engineering Profile (Options > Work Environment > Apply Profile > Structural Engineering Profile), you get a different interface layout, with a few toolbars getting hidden and the set of available tools in the Toolbox limited to structural elements. To see what gets included in these profiles, we open the Work Environment dialog (Options > Work Environment > Work Environment...), which can be a bit overwhelming at first! Here in Figure 2.2, you get a full overview of the different profiles and what is controlled by them.
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			Figure 2.2: Work Environment dialog

			This dialog is very, very extensive, as it allows you to completely reconfigure the Archicad interface, including showing or hiding tools and commands, changing shortcuts, and changing how Archicad works. It even includes options to let Archicad behave like an older version, which may be required when opening some older projects.

			Advanced users often create custom profiles, to include a series of related toolbars and palettes that are focused on the task at hand. You already have profiles for architectural, structural, and mechanical, electrical, and plumbing (MEP) design, but you could also configure one profile that is more oriented toward drafting, one for visualization, and maybe another when training new colleagues, such as a “getting started” profile. When you install other versions of Archicad or extensions, new profiles may be installed as well.

			As for this book, we will stick to the default Architectural Profile and, if needed, we tell you when to switch to another one.

			Understanding Archicad onscreen feedback

			When we model in Archicad (starting in the next chapter!), the software provides a large variety of onscreen feedback. We will dig deeper into how to use this feedback and associated interfaces to our benefit in later chapters, but it is important to define the types of interfaces we will encounter early on.

			Status bar

			At the bottom left of the screen, just below the Quick Options bar, Archicad gives feedback text and instructions on what we should do next when we activate a particular tool—for example, Enter First Node of Line when starting the Line tool, or Complete Line when the first node of a line is already defined. The status bar therefore can be seen as a dynamic quick tooltip, always telling you what Archicad “needs” to be able to perform an action, such as creating a wall or adding a dimension line:
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			Figure 2.3: The status bar in action

			Pet Palette

			The Pet Palette pops up next to your cursor when selecting an element in the Viewport, displaying several relevant options on how you can edit the selection. The selection of icons shown is based on where you click on the element (for example, clicking the endpoints of a line gives different options than clicking the line itself). This is called a contextual menu. Learning how to use this Pet Palette efficiently is key to becoming an Archicad modeling expert, and a lot of its options will be covered in later chapters:
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			Figure 2.4: Some versions of the Pet Palette

			By default, the Pet Palette follows your cursor around the Viewport like a pet, hence its name. If this behavior bothers you, it can also be set at a fixed position through Options > Work Environment > Dialog Boxes and Palettes and setting Pet Palette movement to Jump to preferred position:
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			Figure 2.5: Changing the Pet Palette behavior

			Getting to know the Pet Palette options

			Any Pet Palette can contain a multitude of options/icons, but it is not necessary to know all of them immediately. Most will be introduced throughout this book when we start modeling. If you want to know what a certain option in the palette does, however, you can always hover over the icon and wait for a moment until a tooltip appears, describing the function of any icon.

			Cursor states

			The mouse is the most important instrument for input in the Archicad viewport. To help the user to model accurately and precisely, without having to zoom in and out all the time, the shape of the pointer changes to provide the user with useful and meaningful feedback. This way, we can see immediately if we are clicking a point, edge, or face of an element. This is called the Intelligent Cursor by Graphisoft. It can tell us that we are going to cut/trim an element (by pressing Cmd/Ctrl while clicking), that we are picking up parameters of an element, or that we are injecting those picked-up parameters into something else (by pressing Opt/Alt or Cmd + Opt/Alt while clicking).

			An overview of all cursor states can be found in the Graphisoft Help Center:

			
				
					[image: Figure 2.6: Different cursor shapes (Pencil Shape) during modeling input]
				

			

			Figure 2.6: Different cursor shapes (Pencil Shape) during modeling input

			As an example, Figure 2.6 shows the cursor shape during modeling input, when pointing at empty space, a reference line, other edges, an intersection of edges, a node of a reference line, or other nodes.

			Tracker and other onscreen feedback

			Besides all this visual onscreen feedback, there are even more tools and feedback close to the cursor when we are modeling in Archicad:

			
				
					[image: Figure 2.7: Tracker showing distance and angle, Pet Palette, pencil icon, and Snap Guides]
				

			

			Figure 2.7: Tracker showing distance and angle, Pet Palette, pencil icon, and Snap Guides

			The Tracker gives numeric feedback—for example, the “length” or distance of a line and its (relative) angle to other elements. It can be used for exact numeric input, which we will explain in later chapters. On top of this, there are also all sorts of blue lines appearing in the Viewport, called Snap Guides, further helping the user in modeling accurately and efficiently—for example, parallel or perpendicular to other elements in the current view.

			All this feedback is a lot to take in as a new user, but this book will get you familiar with each of these modeling aids and how to use them to your benefit step by step. They will be explained in combination with the modeling tools, starting from the next chapter onward. Before we start modeling, though, we have to set up our project correctly, as we will see in the next section.

			Setting up your first Archicad project

			When you launch Archicad, you are presented with a welcome screen, which gives you a few options to open a project. You can open one of your recent previous projects, using the tiles, browse for a local file, connect to a BIMcloud project, or you can start a new one from scratch based on one of the available templates:

			
				
					[image: Figure 2.8: Start Archicad dialog, showing a preview of recent projects]
				

			

			Figure 2.8: Start Archicad dialog, showing a preview of recent projects

			When you do select to create a new project, you can choose the template and work environment profile you want to use for this project. Since at this point in this book, you lack the experience to develop a template for yourself, you are advised to stick to the template(s) installed by default. This, again, depends on the language version of Archicad you have access to:

			 

			
				
					[image: Figure 2.9: New Project dialog]
				

			

			Figure 2.9: New Project dialog

			We start here with the Archicad 25 Template.tpl template, which gives a generic but usable setup that can be applied in many situations. It prepares an empty project, with a few views and a full configuration set up for you to work in. Since there are so many aspects of the software we can control and configure, it would be impossible to really start from an empty file, with nothing configured, as it will hinder you in every single step. It is more efficient to work in a template and tweak the configuration if needed—for example, by adding new types or adjusting some of the display settings and view settings. We’ll show you how.

			Project Info

			While not immediately required, it is a good habit to fill in the project information early on. These are properties at the project level, and they can be used later, such as when automatically filling in information for a title block.

			You can access the project information from the menu (File > Info > Project Info...) or by right-clicking untitled at the top of the Navigator and getting a dialog where you can set all the relevant information about the project:

			
				
					[image: Figure 2.10: Project Info dialog (still empty﻿)]
				

			

			Figure 2.10: Project Info dialog (still empty)

			There are sections with details on the project, site, building, contact, and client.

			It may not be immediately obvious, but this information is also included when you exchange files with other project stakeholders: one of the many examples where Building Information Modeling (BIM) is more than geometry—where information is at the core of everything.

			Building stories

			Since Archicad is clearly targeted at the modeling of buildings, it uses terminology and a setup that assumes you are creating a Virtual Building, which is the term Graphisoft launched as a concept in 1987, describing what Archicad stands for, before the BIM acronym became the accepted term in the industry around 2003, more than a decade later!

			When you design a building, multiple stories could be required. Stories in Archicad define the different floor plans you can enter, and they are vertically stacked: they are positioned at a specific elevation, which defines the height to the next story above. Typically, the elevation value of an Archicad building story corresponds with the real-life elevation value of a finished floor in a building.

			Access the Story Settings dialog in the menu (Design > Story Settings...), through the contextual menu in the Navigator (right-click on a story), or press Cmd + 7/Ctrl + 7. You get a tabular overview of all stories in your project:

			
				
					[image: Figure 2.11: Story Settings dialog with default values]
				

			

			Figure 2.11: Story Settings dialog with default values

			The default template has already created a Ground Floor story and two unnamed stories above. You can rename them as you wish and insert new stories above or below the selected one. Note that Elevation and Height to Next are linked: changing the Height to Next setting also modifies the Elevation setting from the story above and vice versa.

			Pro tip

			Here, you may encounter the auto-apply behavior of Archicad: whenever you fill in a value in one of the text or number boxes, Archicad automatically applies this after a small delay. You don’t have to press Enter or close the dialog to apply the value. This gives you the option to continue making changes and it also works in palettes, where there is no OK, Apply, or Close button available. Just enter a value and wait half a second.

			Origin and display grid

			Since an Archicad project is meant to host a construction, you must position it somewhere. As with any computer-aided design (CAD) or BIM software, you must place elements by defining the position of their main reference points against a reference coordinate system.

			Origin

			Archicad uses a Cartesian coordinate system, with a small cross indicating the origin or center of the Cartesian world. While you can start modeling anywhere you want, it is highly recommended to use the Archicad origin as a central point of reference for anything you do—consider it as the origin of the project, with all elements of the projects modeled in the close vicinity of this origin point:

			
				
					[image: Figure 2.12: Archicad origin cross – the “origin” of the project]
				

			

			Figure 2.12: Archicad origin cross – the “origin” of the project

			In many cases, this point will be located at or close to a corner of the building or at some other reference point, such as the crossing of two grid lines.

			Even though Archicad is very flexible in navigating around projects, a good project origin is important for file exchange and collaboration. In fact, it is so important that it is one of those conventions you need to agree upon in collaborative BIM projects.

			Grid

			Another aid when modeling is the grid (View > Grid & Editing Plane Options > Grids & Background): a visual series of lines at a fixed distance, to give a frame of reference toward sizes and scale. Without the grid, you may start to lose grip on the size of the project, especially since you can zoom in or out almost infinitely:

			
				
					[image: Figure 2.13: Grids & Background dialog, to configure Snap Grid, Construction Grid, and grid line colors]
				

			

			Figure 2.13: Grids & Background dialog, to configure Snap Grid, Construction Grid, and grid line colors

			Archicad has two main options for the grid:

			
					The Construction Grid is intended as a larger-scale grid, aligned to typical construction distances, such as 6 m or 7.2 m (typically a multiple of 60 cm, based on human proportion). You can set both a Main Grid and an Auxiliary Grid, with two different repeated grid sizes. This is sometimes used in architectural design, such as Japanese ken/tatami grids or Dutch structuralism when, as an example, you want to have a repetition of two main grid steps and one auxiliary smaller step.

					The Snap Grid is intended as a modeling aid, with rather small snap sizes—for example, set at every 10 cm. It is also applied when “nudging” selected elements, by shifting them by one grid step (Shift + arrow key).

			

			The grid in Archicad can be used for two different purposes:

			
					You can use the grid to snap the position of the cursor, enforcing you to always work at a fixed grid size. This can be helpful when modeling, as the position of walls, slabs, and other elements will be guaranteed upon clicking on the grid.

					You can also use the grid as a visual aid, by displaying lines on the screen. They don’t impact snapping but give a visual clue. This is helpful as the size and proportion of a project are not always easy to interpret on a computer screen, especially when compared to working on paper, where you traditionally had a better feel for the scale of a project. You can set the line color and weight as you want. The default uses thin gray lines on a white background color.

			

			Both options can be combined as you see fit. You can display the grid or not, and you can choose whether it influences snapping or not. For the initial sketch design, snapping to a Construction Grid is convenient, but once you start developing the design in more detail, the Construction Grid is too obtrusive. In that case, you’d probably use the Snap Grid or rely on automatic snapping to the geometry and not the grid.

			We learn in the following chapters how other snapping and guiding methods are available for precise modeling.

			Saving a project file

			Once you have properly configured the basics of your project, do not forget to save the project file in a suitable location, ideally dedicated to this project. This will help to keep things together and ensure that all output can be kept in an easy-to-find location.

			When you save the project, Archicad stores it as a PLN file. This is a single, compressed file, containing everything you have created and configured in the project. It is specific to the version of Archicad you are using, but if needed, you can export the project to a previous version (limited to one earlier version), albeit with a warning that new concepts may not transfer properly.

			You are advised to save frequently, to ensure you don’t lose too much work should anything unexpected happen, such as a freeze of the computer or a crash of the software. Archicad is a complex system and has many features, and while the software is mature and goes through extensive testing, it isn’t entirely possible to rule out bugs that may lead to the software crashing. If that occurs, two things will happen:

			
					Archicad attempts to create a recovery file (created by an auto-save function), allowing you to continue your work.

					Archicad also launches a bug reporter, which gives you the opportunity to send the crash information to Graphisoft, helping their engineers to investigate and solve the issue for future updates or hotfixes.

			

			Pro tip

			In our experience, the recovery file has proven to be quite reliable, and we seldom lose more than a few minutes of work, mainly thanks to the Data Safety settings of the software. They can be accessed through Options > Work Environment > Data Safety and Integrity…. By default, this is set to Ultra Safe, saving every step. This may cause performance issues in more complex projects (for example, where editing a large, complex Curtain Wall takes quite some calculation time for every step), so you may consider setting it to Safe.

			As an additional precaution, Archicad also saves your previous PLN file as a backup BPN file, containing the last saved version of a project, should you want to return to the previous state. However, this is more dependent on how often you save your project manually.

			One final point of attention, should you want to open your project on another computer: the PLN file contains the whole project, but it only keeps references to any library object or texture that was used in the project. These library objects and textures are stored in Library Container Files (.lcf as the extension). This helps to keep file sizes down, but it also implies that the library content is not transferred with your project file. When you just use the default library from your Archicad installation, another user can open the PLN file, and everything gets restored with no issue from that library.

			If, however, they use a different setup that lacks the library you used, this does not get transferred. In that case, you should make an archive copy of your project, by saving it as a PLA file. Here, you have the option to embed the library into the project, for archival usage or for transferring the whole project as a self-contained file. You may opt to only embed the referenced objects, to keep the PLA file size as low as possible. If you embed the full library, your project will be really huge, and this is not needed.

			We can summarize the different Archicad file types as follows:

			
				
					[image: Figure 2.14: Diagram of project, backup, library, and archive files]
				

			

			Figure 2.14: Diagram of project, backup, library, and archive files

			Summary

			So, there you have it. We have looked at the Archicad interface and selected a template and work environment. Then, we started a new project from a template and set up a basic configuration for our project.

			We are now finally ready to get started creating a model!

		

	
		
			3

			Building a Basic Residential Model: Modeling the Construction Elements

			In this chapter, we will cover the basic modeling concepts of Archicad, needed for a first small-scale residential model. Many of the tools and techniques introduced in this chapter will be repeated and expanded later in a second, more complicated model. This is an extensive but necessary chapter. Here are the topics covered in this chapter:

			
					Navigating in 2D/3D and learning the basics of modeling

					Modeling tools in general

					Core construction—walls and slabs

					Using drawing aids in Archicad

			

			Technical requirements

			For this chapter, you will need our demonstration model, which can be downloaded from GitHub (https://github.com/PacktPublishing/A-BIM-Professionals-Guide-to-Learning-Archicad/blob/main/DEMO.pln). Save it to a local folder on your system.

			Navigating in 2D/3D and learning the basics of modeling

			In this section, we will learn how to fluently navigate through and interact with a model in both 2D and 3D.

			Opening your first model

			Before we can learn how to navigate in 2D and 3D, we need a model. For this, we will use the demo model that you just downloaded. We will use this example throughout this chapter to learn how to navigate in Archicad.

			You can open the model by either double-clicking it in your Finder/Explorer (hence starting the Archicad application) or by first starting up Archicad and browsing for the file through File > Open > Open... (Cmd + O/Ctrl + O), clicking Open once you have selected the correct project within the right folder in the following dialog screen:

			
				
					[image: Figure 3.1: Opening a project from within a running Archicad session]
				

			

			Figure 3.1: Opening a project from within a running Archicad session

			Archicad models in the cloud

			Storing models in the cloud is not advised in most cases. The backup process of Archicad (creating the .BPN file) may conflict with the synchronization processes of your cloud service of choice. Some cloud storage solutions offer an option to keep a file or folder on your hard disk permanently. In such a case, using this file/folder for Archicad might work better. More information is available at Graphisoft Community (https://community.graphisoft.com/t5/Project-Management-articles/Sync-utilities-and-issues-with-Save-operation-in-ARCHICAD/ta-p/303937). Note this is not the same as using BIMcloud from Graphisoft, which is designed specifically for storing and sharing collaborative Archicad projects.

			The main part of the Archicad interface (the Viewport) is where you will interact with the building. Since buildings are much larger than your screen, you will need to learn how to navigate around the model through the various views.

			Navigating in 2D

			In this section, we go through the basic operations and explain the related mouse movements and shortcuts.

			Panning

			Panning is the equivalent of moving your display, drawing, or another view sideways, without changing its size. You can pan up, down, left, and right. This is one of the core navigation methods of Archicad, and there are a variety of methods to pan.

			Technical prerequisite

			Open the demonstration model—1. Story should be the default view when opened. This is also shown in the Navigator on the right-hand side, marking this story in bold text.

			When using the mouse, you press and hold the middle mouse button (MMB—the scroll wheel) to drag the view left, right, up, and down. The cursor changes to a hand to indicate panning:

			
				
					[image: Figure 3.2: Panning a floor plan diagonally (right + upward) using the MMB]
				

			

			Figure 3.2: Panning a floor plan diagonally (right + upward) using the MMB

			With the Apple Magic Mouse, there is no MMB, so you slide your finger left, right, up, and down instead.

			Using the keyboard, you can use the arrow keys to navigate the view in small steps. The arrow indicates the direction in which you want to move, which is the opposite of the direction in which the view itself will move. It sounds more complicated than it is, really.

			You can also pan using the trackpad, by swiping with two fingers at the same time.

			Zooming

			You can display the model at any scale, from an overview of the whole project up to the finest detail. You use the Zoom navigation command to enlarge or shrink the display of the model. However, the model is always at the same absolute size! Zoom in to look in more detail; zoom out to get a large overview.

			When using the mouse, you scroll the mouse wheel to zoom in and out. Archicad will smoothly enlarge or shrink the display. Beware that the position of your mouse will remain the focal point for the zoom navigation. When you hold down Shift, this will increase the speed of zooming.

			With the Apple Magic Mouse, there is no scroll wheel, so you use a finger swipe combined with the Option key. It works well but requires two hands.

			Using the keyboard, you can press - (minus) to zoom out and + (plus) to zoom in. This works best when you have a separate numeric keypad, which is not always available if you work on a laptop.

			Finally, you can also zoom using the trackpad, by pinching two fingers. This works quite intuitively, but only if you have a large trackpad, such as on a MacBook Pro.

			Navigating around like a pro

			Take some time to learn these two navigation methods. With the mouse, you can immediately switch between zooming and panning, which you’ll have to do continuously when working in Archicad. Try to move around, pick a small region of interest, and see if you can bring it up close, in the middle of the display. Switch between the different shortcuts (mouse, keyboard, and trackpad) to get a good grip on navigation.

			When you want to bring the whole project into the center of the view, you can use the Fit in Window command. You find this command in the menu (View > Zoom > Fit in Window), using the shortcut displayed in the menu or just double-clicking your MMB. The same command is also available in the context menu (Ctrl + left-click or right-click):

			
				
					[image: Figure 3.3: Zoom commands in the View > Zoom submenu]
				

			

			Figure 3.3: Zoom commands in the View > Zoom submenu

			In the same menu, you also get the option of zooming the view to its actual size, at 100%. What does this mean? This is an approximation of the view at print size, for the current display scale (for example, 1:100; 1:50).

			Both Fit in Window and Actual Size (through Current Zoom Factor > 100%) can also be activated from the buttons in the Quick Options bar below the Viewport:

			
				
					[image: Figure 3.4: Zoom options in the Quick Options bar]
				

			

			Figure 3.4: Zoom options in the Quick Options bar

			Contextual menu

			The contextual menu will be used throughout the book. You can always access it, in any view or layout, by using the right mouse button (RMB) or the Ctrl + left mouse button (LMB) combination if you are a Mac user. We already encountered it briefly in Chapter 2, in the Building stories section.

			And even further navigation

			After you select an object by left clicking on it, an additional Zoom to Selection command becomes available. It can be found in the menu (View > Zoom > Zoom to Selection) or in the context menu. This adjusts the zoom so that the object gets framed as large as possible in the center of the view.

			Note

			You may have noticed by now that Archicad is a professional application, with loads of commands and variants to cater to a wide variety of situations. You are advised to start with the basics but also be attentive to the shortcuts displayed in the menus so that you can pick them up gradually. We are not going to overwhelm you with every possible command, variant, and shortcut. You’ll remember them best when using them repeatedly.

			Configuring mouse behavior

			If you don’t like the default behavior of the mouse wheel or Magic Mouse, you can configure them differently in the work environment (Options > Work Environment > Input Constraints and Guides). Here, you can alter the way the mouse wheel, Magic Mouse, and trackpad react. The options are slightly different between Windows and macOS, obviously:

			
				
					[image: Figure 3.5: Configuring mouse and trackpad behavior via Input Constraints and Guides]
				

			

			Figure 3.5: Configuring mouse and trackpad behavior via Input Constraints and Guides

			Navigating in 3D

			So far, we have stayed in the 2D floor plan window. At any given moment, you can switch to a 3D window. This can be done from the menu (Window > Floor Plan / 3D Window) or using the F2/Fn + F2 and F3/Fn + F3 shortcuts respectively. If you have a Touch Bar on your Mac, these two options are shown using an icon and text.

			From within the 3D window, the main methods of navigation (pan and zoom) still apply, and they work mostly the same: scroll to zoom, drag with the MMB to pan, and the related swipes from the Magic Mouse or trackpad. You also have the Fit to Window and Zoom to Selection methods, as in a 2D window.

			However, two additional navigation methods help you to easily navigate around the model in a 3D window.

			Orbit

			When you want to look at the model from a different angle, you can rotate around the model with the Orbit command. This is performed by holding down Shift and dragging with the MMB. On the Magic Mouse, you also press Shift but will have to swipe instead. Shift works even when you swipe the Trackpad with two fingers. You can see a visual representation of Orbit being used here:

			
				
					[image: Figure 3.6: Different viewpoints during Orbit]
				

			

			Figure 3.6: Different viewpoints during Orbit

			All these navigation gestures are temporary, while you hold down Shift. If you want to remain in Orbit mode, you can press o as a shortcut. Now, the Orbit command remains active, and you can orbit using the regular LMB or the trackpad. Orbit is a very important method, so practice it a bit before you continue. You will use it all the time.

			Explore (or the “game” mode)

			When you are in a 3D window, the Quick Options provide a navigation method that is inspired by gaming. Explore uses a mouse/keyboard combination, just like typical 3D shooting or exploration games:

			
				
					[image: Figure 3.7: Accessing the Explore navigation mode]
				

			

			Figure 3.7: Accessing the Explore navigation mode

			It introduces a whole new set of shortcuts and navigation gestures that will feel very familiar to gamers. To help you, Archicad displays them in a dialog, so take a few seconds to read through the options.

			Remember to press esc, or click with the mouse, to exit the Explore mode. Archicad reminds you about this at the bottom of the main window, where a few additional options are presented, such as switching between walking and flying.

			Take some time to explore the model and imagine how it would feel when roaming your own project in real-time 3D. This is very helpful, not only for presentations but also as a designer.

			Modeling tools in general

			We are almost ready to start modeling on our own. While Archicad has a huge set of modeling commands, they all behave quite similarly and are structured the same way. Once you can model a linear element, such as a wall, it is not difficult to apply the same methods to create a beam, and you will see similarities between both tools with the basic 2D Line Tool. And after you have learned how to draw a slab, roofs and fills use the same approach, as their geometry is all contour-based.

			Here are a few common behaviors or methods, which are available for many tools:

			
					Archicad distinguishes between Default settings and Selection settings in the Info Box. The properties displayed in the Info Box are either those from the currently selected element (Selection settings) or, if no element is selected, the setting that will be used for the next element you create (Default settings). Each tool remembers the last settings that were used, and these become the default settings for that tool in the project.

					Elements are typically created in a floor plan window, closely resembling 2D drafting on a drawing board or computer-aided design (CAD) software. This defines the position and horizontal extent of elements. Each floor plan is related to a building story, so whenever you place an element, it will be linked to that story, which becomes its home story. Some objects can also link their height to a story, such as walls and columns. This allows you to adjust the story settings while retaining the vertical linkage of the elements in the stories.

			

			Home story

			The home story of any element in Archicad is the story where this element “belongs”—just like in the real world (when the project is constructed). Setting the home story correctly is key to getting good 2D visualizations (for example, showing all elements on a floor plan of a certain story) but also helps with tracking quantities in schedules (for example, grouping elements and their quantities per story), so keep an eye on this setting!

			
					Some elements, such as walls or slabs, have an internal structure. This defines their composition, by assigning building materials (discussed later). There are three main types of structure: Basic, Composite, and Complex profiles. We will encounter all of them throughout the book.

					When creating a linear element, it is typically defined by its reference line: this is the imaginary line between its start and end points or nodes. The actual geometry is then set relative to the reference line. This reference line also defines the way elements can automatically connect—at corners, T-joints, or other combinations.

					Many tools provide different geometry methods during modeling. This defines how the user will enter the main reference points, lines, or contours of the element. The available geometry methods differ between tools but are quite similar: linear, rectangular, and polyline methods are used for many tools. The geometry method is typically selected before entering points, but it can be toggled during input.

					Last, but certainly not least, each element is placed on a layer, which is very similar to other CAD software. Layers are used to control the visibility of elements. When you hide a layer, all elements on that layer get hidden too. When you start a project, you are presented with a default set of layers. The visibility of the different layers is managed as a layer combination so that they can be retrieved easily.

			

			Note

			We return to all these concepts several times, so don’t worry if you didn’t fully understand their purpose right now. If you pay close attention, you’ll quickly figure out that the different tools in Archicad are very similar: once you have learned a few techniques, they can be applied to many other commands as well, so you don’t have to relearn them for other elements.

			Finally, we are now ready to start modeling our very first project. Through the upcoming parts of the book, we will learn the skills to model a complete small residential building—the example house you used to learn how to navigate in Archicad. It will take a lot of steps and a variety of techniques, but we will take it slow and explain every step along the way.

			Core construction – walls and slabs

			In a Building Information Modeling (BIM) context, we should mention that we are always drawing or modeling on a 1:1 scale. In CAD systems, this is not always the case, as they apply drawing units linked to a certain real-life measurement (for example, 1 drawing unit = 1 mm). Since Archicad lets you create a virtual building, it makes sense that we use the real-life size to model this. We will learn later how to create different views, representing our design at different scales and with dimensions displayed in the units we want for a specific view.

			Starting a new project

			Start a new project (File > New > New... or Cmd + N/Ctrl + N), using the Archicad 26 Template.tpl and Architectural Profile 26 templates as the work environment. Default story settings will suffice for now.

			Modeling the basic shape of the ground floor

			We will start creating our project by modeling a rectangular shape on the ground floor using the Wall Tool:

			
					Activate the Wall Tool in the Tool Box.

					Choose Rectangle for Geometry Method, by clicking the first option in the Info Box and holding the LMB for a moment (four options appear: Single, Chained, Rectangle, Rotated Rectangle) and then choose the third option:

			

			
				
					[image: Figure 3.8: Starting the Rectangle tool and choosing the appropriate geometry method]
				

			

			Figure 3.8: Starting the Rectangle tool and choosing the appropriate geometry method

			Note

			When clicking buttons in the Info Box marked with an arrow for at least 0.5 seconds, that button will expand and offer more applicable options for that setting. This way, the work environment is kept as efficient as possible.

			
					Set Reference Line Location to Outside Face as we will edit the wall structure later, and the reference line is the fixed part of our wall contour—we come back to this concept in Chapter 4 :

			

			
				
					[image: Figure 3.9: Choosing the best location for the reference line]
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