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			Foreword

			How Power Query Changed OUR Lives

			Ken’s Story: “Coffee & Power Query”

			It’s the name on the meeting in my Outlook calendar from back in November 2013. It was during one of the Microsoft MVP summits, the product had recently had its name changed from Data Explorer, and I was meeting with Miguel Llopis and Faisal Mohamood from the Power Query team over coffee to talk about the good and the bad of the tool from an Excel users’ perspective.

			In that conversation, I told them both that Power Query was great, but it was a lousy replacement for SQL Server Management Studio. I distinctly remember that part of the conversation. I’d been working with SSMS and Power Query a lot at the time and was struggling with the fact that Power Query did some of the same tasks, but not all. I was frustrated, as I was struggling with the tool, trying to make it behave the same, but it just wasn’t doing it.

			What happened after I laid out my concerns flipped my complaints on their head. I’m paraphrasing from my memory, but the response was something like this:

			“Ken, this tool isn’t a replacement for SSMS. We built this for Excel people… our intent is that they never need to use or learn SQL at all.”

			For anyone that knows me well, they know that I’m very seldom left speechless, but that was just about enough to do it. That statement upset the balance of my world.

			Understand that I’m not a normal Excel pro. I know enough SQL to be dangerous, I’m extremely accomplished with VBA and had also worked with VB.NET, C#, XML and a few other languages. And while I love technology and challenges, the true reason I know as many languages as I do today is that I taught myself out of necessity. Typically, my needs were complicated, and that involved a painful journey of jumping into the deep end with a “sink or swim” approach.

			That meeting changed my view of Power Query forever. I took a step back and looked at it in a new light. And I started to use it as it was intended to be used… on its own, driving everything through the user interface, avoiding writing SQL wherever possible. And you know something… it started working better, it allowed me to go more places, it allowed me to solve things I’d never been able to do before.

			I love this tool. Not just because of what I can do with it, but because of how easy it makes it to get things done for a business pro without the need for coding. Yes, there is a coding layer within the tool that you can learn, but it is entirely optional. That is what makes this tool so special: it has one of the best user-interface designs I’ve seen in a long time, which essentially writes code for you as you click buttons. I love this tool because the people we teach can pick it up rapidly and build complex solutions that add real business value in an incredibly short amount of time. This product is truly centered around the business professional.

			On a personal note, Power Query has allowed me to quit my full-time corporate job and build my own business. We deliver live training (in-person or online), as well as our own commercial Excel add-in – Monkey Tools – which can help make your life even easier when working with Power Query and Power Pivot in Excel. Ultimately, there is nothing that gets me more excited than seeing someone find that magic moment that significantly impacts their workflow and saves them time.

			Miguel’s Story: A new beginning

			Before starting my business as a freelancer in 2013, I had a reputation in my past jobs of being the “power user”, so I kept that nickname even after leaving those jobs and that’s how I named my YouTube channel and now my new website ‘The Power User’.  

			I was never in IT, but I was usually the guy trying to push things forward in terms of how technologically advanced we were and how much value we could get from the tools that we had at hand, which was usually just Excel (and not even the latest version). Pivot Tables and Excel formulas ended up becoming like second nature to me. 

			Fast forward to 2013 and I got introduced to Power Query. I can’t really remember how I got to it, but things like simply filtering data, removing columns, promoting headers, and unpivoting columns had a huge impact on my day to day. I had no knowledge of VBA (and I still don’t), so Power Query literally opened completely new data wrangling opportunities for me which were previously impossible. I no longer needed to become a VBA or SQL Expert – I just needed Power Query and my data preparation issues would be gone.  

			The Power Query user interface was the hook for me. It felt intuitive and is the type of interface that puts you right in the driving seat in front of what matters most to you - your data. However, since it was a new tool and a new language, there was little content or information on the web about how to get the most out of Power Query, so I started my journey to be “the very best, like no one ever was” on this new technology and started creating content for it. 

			Through this new content creation (blogging, videos, emails, etc.), I ended up meeting people like Rob Collie and Bill Jelen who later introduced me to Ken who was also big on Power Query. Ken and I never met in person, but we decided to work together because we felt we complemented our views on Power Query and we both wanted to “preach” about how amazing Power Query is. We started a project called 
PowerQuery.Training which ended up fostering the content that got published in the first edition of our book. During that period of writing the first edition and even before that, we realized the true potential of Power Query and how it could change the lives of most Excel users for the better. For us, Power Query was and still is a major breakthrough as far as self-service tools go. 

			Ever since we published the first edition of our book, readers, friends, and colleagues have reminded us that some of the pictures and the content in that first edition was getting outdated, but that the content was still a solid foundation, and it opened their eyes to see the potential that Power Query has. That has been our north star since the very beginning – we’re on a mission to change people’s lives the same way that this tool changed our lives and made data preparation simple and straightforward. 

			From 2015 to 2021, Ken and I received more and more confirmation from the readers of our book that Power Query is changing people’s lives; either directly or indirectly. Hearing that type of feedback always put a smile on our faces. It’s reassuring and it’s also the main motivation why we decided to write a second edition of the book the way that we did. We wanted it to be done just right and for that, we needed to wait for the right time.  

			In May of 2021, I was asked if I would be interested in joining Microsoft as a Program Manager on the Power Query team. To me, this means taking a new role but following the same mission – to bring Power Query to more people and have a positive impact in the way they work.

			As this book is going to print we are still working out the formal contractual details and start date of the position, but I can’t put into words how motivated I am for this new role.  And if you needed an example of how Power Query can change people’s lives, I’m one example of how much it can.

			Author Acknowledgements

			As with any book, there are a bunch of people who are quite influential with making things happen. Without the influence of the people below, this book would never have come to fruition:

			Bill Jelen – We cannot imagine working with someone who is more accommodating than Bill. Writing a book involves a huge amount of time and effort. Just balancing that against our own business needs is tough, but when the book is based on technology that changes as quickly as Power Query is changing… And then, with very short notice, we dropped a book on his lap that was twice the length of what we had originally promised. Bill accepted every delay and change with grace and understanding, encouraging us on a regular schedule to get the book finished.

			Miguel Llopis – From the very first meeting over coffee, Miguel has been our go-to guy at Microsoft, even joking that his full-time job is answering Ken’s emails. He’s been incredibly supportive since day one, has responded to feature design requests, bugs and so much more.

			Curt Hagenlocher, Ehren Von Lehe, Matt Masson, and all the others on the Power Query/Power BI team – We cannot begin to express how willing this team has been to talk to us and answer our questions and emails. Their help and clarifications have been incredibly helpful in turning out the finished product.

			Wyn Hopkins, Cristian Angyal and Matt Allington – For the feedback and opinions on some material that we were particularly concerned that we had pitched correctly.

			The countless people that have commented on our blogs and videos, attended our training sessions, and shared their own creative and alternate solutions with the world. Each of you has helped challenge us to explore new methods, develop better techniques, and have a lot of fun with this program. 

			Ken would like to thank:

			Our previous book started with an email on Mar 6, 2014, introducing me to Miguel Escobar. He had a dream; to write a book on Power Query. Despite the fact that we’d never met in person – and still wouldn’t for several years – Miguel’s ideas and energy have had a profound impact on me. They led to the creation of our initial book (M is for Data Monkey), an online Power Query Workshop, our Power Query Academy, and now a second edition of the book. Without his inspiration and devotion to these projects, none would have come to fruition. His passion has continued to push my personal growth with Power Query, particularly when working with the M language itself. I am still trying to figure out how he can work 24 hours per day though!

			This book would never have been finished without the support of my family. Even more than being a rock in my corner, my wife Deanna did the initial proof-read of every page of this book, (several times), fixing my spelling and clearing up the odd wording that I sometimes write down when my brain is a paragraph ahead of what my fingers are typing. I also need to give a shout out to my daughter Annika who taught me all about the Oxford comma (including the fact that Taylor Swift doesn’t use them). I only wish she’d shared that wisdom with me more than 72 hours before the manuscript was submitted!

			We now have a team of people at Excelguru who held down the fort as I locked myself away to complete this manuscript: Rebekah Sax – who handles everything we throw at her with grace, Abdullah Alharbi – who gets tossed a rough idea for Monkey Tools that he has to bring to fruition in code, and Jim Olsen – my friend, mentor and former manager who now looks after our accounting for us. Without each and every one of you doing what you do, there is no way that we would be as successful as we are, or that I would have been able to finish this project.

			Anyone who works on the Excel team can tell you that I deliver fairly passionate feedback about the product. I’m fairly certain no one has been on the receiving end of that more than Guy Hunkin, who lives at the nexus of both Power Query and Excel, tasked with the integration of the two technologies. Guy’s endless patience absolutely amazes me, and I can’t thank him enough for always taking my feedback professionally, but never personally. Beyond our emails and calls, I’m lucky enough to have had Guy attend a couple of my training courses where he took copious amounts of notes which have led to several things being fixed or changed.

			Finally, I’d like to thank our business partner Matt Allington. Matt joined Miguel and I at the beginning of the COVID pandemic in mid-2019, in order to expand the Power Query Academy and our business operations. Since then, we have re-branded to become https://skillwave.training – and now offer both self-paced and coached training in Power Query, Power Pivot, and Power BI (among other topics). Matt has been a friend for many years, but of particular importance to this book was some advice on scheduling and prioritizing that actually allowed us to get it over the finish line.

			Miguel would like to thank:

			I’d like to thank YOU for reading this. Yes…YOU! You’re a crucial part of our main objective and our intention with this book is to provide you with the resources so you can become a Data [M]aster, Data [M]agician, and, above all, a great Data [M]onkey in the most positive way possible. I’d like to thank you in advance for making this world a better place – at least in the context of business decision making and the world of data. 

			I’d also like to thank all of the Excel and BI practitioners worldwide that have shown their support towards our book and our Power Query related endeavors. It is truly an honor to be part of this worldwide community and I invite you to join us by simply using this tool.

			Let’s not forget about a crucial part of my life: Friends and Family. I’m not putting names in here as I’m afraid I might leave someone out of it – so I’m playing it safe here! :)

			Special thanks to Ken for being extremely supportive and being able to overcome the language barrier at times with me! “Spanglish” gets me sometimes, yet Ken distinguishes what I’m trying to say and makes a better version of it.

			Also, special thanks to Curt Hagenlocher, Ehren Von Lehe, Matt Masson, and Miguel Llopis from the Power Query team who I’ve been spamming with questions, bugs, rants, suggestions, ideas and overall complaints about Power Query since 2013 and, to this day July 4th 2021, they still haven’t ignored me or just told me to stop – if you need some classes about patience and customer service, you should speak with them someday :). They are the real MVPs. 

			Our Loyal Supporters

			There are a great many of you who pre-ordered this book when it first went on sale at Amazon, and/or you signed up for the Power Query Academy at https://skillwave.training (or https://powerquery.training). Each of you has been promised a copy of this book and has been waiting a LONG time to actually see it arrive at your door. THANK YOU for both your support and your patience. We truly hope that you feel that it was worth the long wait.

			And finally…

			A huge thank you to our Power Query Academy members at Skillwave.Training who jumped on the opportunity to proof-read the book on a very tight schedule.  We especially want to throw a shout out to Seth Barron, Randall McHenry, Stanton Berlinsky, John Hackwood, Mitchell Allan, Nick Osdale-Popa, Mike Kardash, and Lillian, each of whom submitted over a dozen spelling and grammar fixes through the book.

			We’d also like to thank YOU. For both buying the book, putting your trust in our teaching methods, and for becoming part of the Power Query movement.

			This book was written for you, in an effort to help you master your data. We truly hope it does, and that you’ll find it to be the most impactful productivity book you’ve ever purchased.

			We’d like to thank YOU. For both buying the book, putting your trust in our teaching methods, and for becoming part of the Power Query movement.

		

	
		
			Chapter 0 - The Data Revolution

			The Common Scenario of the Data Analyst

			Whether we are performing basic data entry, building simple reports or designing full-blown business intelligence solutions using VBA, SQL and/or other languages, we all deal with data to a certain extent. Our skill sets vary greatly, but the overall jobs we are usually trying to perform include:

			
					Extracting the data from a data source,

					Transforming the data to our needs,

					Appending data sets,

					Merging multiple data sets together, and

					Enriching our data for better analysis.

			

			We are Information Workers. And no matter what you call yourself in your formal job description, our role is to take our data, clean it up, and turn that data into information. Our job may not be glorious, but it is essential, and without our work done correctly, the end results of any analysis are suspect.

			Naturally, our tool of choice for years has been Microsoft Excel. And while tools like Excel have amazing functionality to help us build business intelligence out of data, converting raw data into consumable data has been a challenge for years. In fact, it’s this issue that we can often spend most of our time on; prepping the data for analysis, getting it into a nice tabular format so that it can be consumed by analytical and reporting tools.

			[image: ]

			Behind the curtains, we are all information workers trying to reach our desired goal with data

			To those who have done our jobs, they’ll know that we are more than just Information Workers; we are Data Magicians. Our data seldom enters our world in a ready-to-consume format, instead it can take hours of cleaning, filtering and re-shaping to get things ready to go.

			Once our data is prepared and ready, we can perform a vast array of powerful analytical processes with ease. Conditional formatting, filters, pivot tables, charts, slicers and more, each of these tools will open up to us and let us weave the true magic to impress our audience.

			Our issue comes much earlier in the process. We’re served dirty data, held in collections of text and Excel files (maybe a database if we’re VERY lucky) and we somehow have to clean it up and get it ready to use. Ultimately our end goal is simple: get the data into a tabular format as quickly as possible, while ensuring it is scoped to our needs, and accurate. And with every solution needing a different combination of data coming from different sources… it takes magic.
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			Black Magic: What really happens to data before consumption

			The Benefits and Dangers of Black Magic

			And the true wizards of Excel use many different techniques to weave their magic; sometimes on their own, and sometimes in combination with other tools. These types of magic include:

			
					Excel formulas – These are some of the first techniques that the magician will often reach to, leveraging their knowledge of formulas such as VLOOKUP(), INDEX(), MATCH(), OFFSET(), LEFT(), LEN(), TRIM(), CLEAN() and many more. While formulas tend to be used by most Excel users, the complexity of these formulas varies by the user’s experience and comfort.

					Visual Basic for Applications (VBA) – A powerful language that can help you create powerful and dynamic transformations for your data, these techniques tend to be used by advanced users, due to the discipline required to truly master them. 

					SQL Statements – Another powerful language for manipulating data, SQL can be extremely useful for selecting, sorting, grouping and transforming data. The reality, however is that this language is also typically only used by advanced users, with many Excel Pros not even knowing where to get started with it. This language is often confused with being the sole domain of database professionals, although every Excel Pro should invest some time in learning it.

			

			Each of these tools has something in common; they were essentially the only tools that we had in order to clean and transform our data into something useful.

			Despite their usefulness, many of these tools also had two serious weaknesses: the time needed to build the solution and the time needed to master the techniques.

			While it’s true that the truly savvy magicians could build solutions to automate and import raw data in a clean format, this took years of learning advanced languages, and then a significant amount of time scoping, developing, testing and maintaining the solutions. Depending on the complexity of the solutions built, fixing the solutions for a minor change in the import format, or extending them to embrace another source could be horrendous.

			Which leads to a third danger of having a true wizard in the company; they build an incredible solution which works until long after they’ve left the company. It’s only then that the company realizes that they didn’t understand the solution, and don’t have anyone to fix it.

			On the flip side, many people tasked with this data cleanup didn’t have the time or opportunity to learn these advanced magic techniques. And while we could say that maybe they’re better off never having a massive system collapse without anyone to fix it, instead they waste hours, days, weeks, months and years of labor time and money performing repetitive data cleanup and imports on a regular basis.

			Take a moment and think about how many hours are consumed on a monthly basis in your company simply performing repetitive data import and cleanup tasks in Excel. Multiply those hours by the average wage rate in your company. And by the number of companies in your industry world-wide and… do we need to go bigger? The cost of lost productivity in this area is staggering.

			We need a better way. We need a product that is easy to learn, that others can pick up and understand with limited instruction. We need a product which lets us automate the import and cleanup of data, letting us focus on turning that data into information, adding true value to our company.

			That product is finally here. It’s called Power Query.

			The Future Transforms

			Power Query is the answer to our data issues and solves the earlier issues of each of the toolsets. It is very easy to learn, having one of the most intuitive user interfaces we’ve ever worked with. It’s easy to maintain, as it shows each step of the process, which can be reviewed or updated later. And everything done in Power Query can be refreshed with a couple of clicks. 

			From the perspective of two people who have spent years building solutions using black magic techniques, Power Query is a game-changer for many reasons. One of those is the speed with which it can be learned.

			When specifically trying to import, clean and transform data to get it ready for analysis, Power Query can be learned faster than even Excel formulas, and handles complex sources much more easily than VBA: 
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			Power Query was designed to be an easy-to-use Data Transformation and Manipulation tool

			The ease of use is actually the reason we believe that this tool is the answer to the issue of the vanishing data magician that faces so many businesses. Even if that magician builds something complex in Power Query, you can have someone up to speed to be able to maintain or fix the query with minimal training, (as in hours, not weeks).

			As hard as it is for true Excel Pros to understand, many users actually don’t want to master Excel formulas. They simply want to open up a tool, connect it to their data source, click a few buttons to clean it up and import it, then build the chart or report they need. It’s for exactly this reason that Power Query’s reach will be even broader than those users who master formulas. With the menu-driven interface, a user never has to learn a single formula or line of code in many cases. 
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			Power Query’s ease of use will impact more users than any of our classic methods

			There is no doubt in our minds that Power Query will change the way Excel Pros work with data forever.

			We also want to make it quite clear here that we are not discounting the value of formulas, VBA or SQL. In fact, they are tools that we could not live without. Formulas can be knocked out quickly outside the tranformation context to do many things that Power Query will never do. VBA has a far greater reach in sheer capability and power, allowing us to reach to other applications, create programs to pull and push data, and so many other things. And a SQL query written by a SQL wizard will always be faster and better than that created by Power Query.

			In the context of simply connecting to, cleaning and importing data, however, Power Query offers more for less, allowing us to automate the job more quickly and with less investment in time. And with the constant improvements made by the Power Query team, those gaps between the SQL pro and the Power Query generated queries are shrinking.

			As impactful as this is for Excel users, it’s important to recognize that Power Query is not just about Excel. In the past, if you’d built a system in Excel to transform and load data, it would need to stay in Excel or be totally re-written in a new language. But Power Query offers your data transformation process a “grow-up” story. The reason is that the same Power Query technology is in use in Excel, Power BI Desktop, Power Automate and Power BI Dataflows. So today, when you’ve built a solution using Power Query in Excel, you can simply import it into Power BI Desktop, or copy it into Power BI Dataflows.

			Beyond creating portable and scalable solutions, this means that as data pros, we can learn a new portable skill and re-use it many times across various different software products. And even better? We have no reason to expect that Power Query won’t expand beyond these footprints.

			And with its solid integration into other software, we get the best of both worlds. We can provide our own SQL queries to Power Query if needed, refresh it with VBA in Excel or schedule the refresh via Power BI when desired, load our Power Queries directly into data models or entities, and so much more.

			Why Power Query IS Magic

			The number one issue facing the data pro when building robust and stable solutions has been accessing, cleansing and transforming the data. What we’ve needed, and yet many of us have never heard of, is an ETL tool:
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			ETL: Extract, Transform, Load

			Power Query is an ETL tool; its function is to Extract data from almost any source, Transform it as desired and then Load it. But what does that truly mean to us as functional data pros?

			Extract

			Extraction can be targeted against one or more data sources including the following: Text files, CSV Files, Excel Files, Databases and Web pages. In addition, the Power Query team has built many connectors to data sources that have otherwise been tough to get at: Microsoft Exchange, Salesforce and other “Software As A Service” (SAAS) sources that you’d never have expected. And naturally, there are ODBC and OLEDB connectors for those databases that haven’t yet been covered by the team. No matter where your data lives today, there is a very solid chance that you can extract it and use it with Power Query. 

			Transform

			When we talk about transformation, we include each of the following areas:

			1.Data Cleansing – This includes filtering out departments from a database, to removing blank or garbage rows from a text file import. Other uses include changing cases from uppercase to lower case, splitting data into multiple columns and forcing dates to import in the correct format for your country. Data cleansing is anything you need to do to your data to clean it up to be used.

			2.Data Integration – If you use VLOOKUP(), INDEX()/MATCH() or the newer XLOOKUP() formulas in Excel, then you’re probably integrating multiple datasets. Power Query can join data in either vertical or horizontal fashion, allowing you to append two tables, (creating one long table), or merge tables together horizontally (without having to write a single VLOOKUP() function). You can also perform other operations such as grouping and more. 

			3.Data Enrichment - These tasks include adding new columns or doing calculations over a set of data. From performing mathematical calculations like creating Gross Sales by multiplying Sales Quantity * Sales Price, to adding new formats of dates based on your transaction date column, Power Query makes this easy. In fact, with Power Query you can even create entire tables dynamically driven based on the value in an Excel cell, SQL dataset or even a web page. Need a dynamic Calendar table that runs five years back from today’s date? Look no further than Power Query.

			What is truly amazing about Power Query is how many transformations can be performed through menu commands, rather than having to write formulas or code to do it. This tool was built for end-users and requires no coding experience whatsoever in order to perform transformations that would be incredibly complex in SQL or VBA. That’s a great thing!

			If you are the type of person who likes to get under the covers and tinker with formulas or code, however, you can. While there is no requirement to ever learn it, Power Query records everything in a language called “M” (we joke that languages A through L were taken). And for those wizards who decide to take advantage of this language, we can build even more efficient queries and do even more amazing things.

			No-code, low-code or pro-code: the option is totally up to you. But no matter which way you choose to go, you’ll be floored with just how much can be done in the no-code world.

			Load

			As each program that supports Power Query has different uses, the locations you can load your data to will vary:

			1.Excel:  Load to Excel Tables, the Power Pivot Data model, or only to Connections

			2.Power BI:  Load to the Data Model, or only to Connections

			3.Power Automate (Flow):  Load to Excel workbooks (and we expect more destinations in future)

			4.Dataflows:  Load to Azure Data Lake Storage, Dataverse, or to Connection Only

			The “Connections” might seem a bit mysterious, but it simply means that we can create a query that can be used by other queries. This allows for some very interesting use cases that we’ll explore more fully in the book.

			While it’s interesting to look at where the data loads, that really isn’t the important part of the Load process in this ETL tool. It’s how it loads, or rather how to load it again.

			Power Query is essentially a macro recorder, keeping track of every step you use when you work through the Extract and Transform steps. This means that you define your query once and determine where you’d like to load it. After you’ve done that you can simply refresh your query. 
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			Define the transformation process once and consume anytime

			Consider this for a moment. You import your text (.TXT) file, the one it used to take you 20 minutes to import and clean each month before you could use it. Power Query makes it easy, allowing you to accomplish the same task in 10 minutes, saving you 10 minutes the first time you use it. Then next month comes along and you get a new file…

			Until now, you’d roll up your sleeves and re-live the 20 minutes of Excel exuberance where you show Excel that you’re a master at reliving the past, performing those exhilarating steps over and over again each month… wait… you don’t find that exhilarating?

			In that case, just save your new .TXT file over the old one and click Data → Refresh All in Excel (or Home → Refresh in Power BI). You’re finished. Seriously. And if you’ve published the file to Power BI or set it up in Power BI Dataflows, you can just schedule the refresh to avoid even that hassle!

			This is the real power in Power Query. Easy to use, easy to re-use. It changes your hard work into an investment and frees up your time next cycle to do something worthwhile.

			Power Query Experiences & Product Integrations

			Power Query is a technology that is revolutionizing the world. It officially started in Excel back in 2013 as a COM add-on and it is now in over 8 different products ranging from Excel and Power BI Desktop, to SQL Server Integration Services, Azure Data Factory, and is probably being integrated in your favorite data-related Microsoft product as you are reading this book. 

			The impact that Power Query is having is phenomenal and is dramatically changing the lives of many data professionals across many different software products. The downside is that being integrated into so many products comes at a cost. The difficult situation that the Power Query team faces on a daily basis is balancing parity of functions, features and experiences throughout all these product integrations. They have to strike the sweet spot between consistency as well as features that are specific to the product that is hosting the Power Query feature set.

			The Components of Power Query

			You can think of Power Query as somewhat of an onion – it has layers – which are effectively the core components that make Power Query, well… Power Query.

			Whenever we look at physical things, we see them at face value. As you progress through this book, you’ll learn that there is a lot that happens behind what we first see from Power Query. There is M code – which is visible to us – as well as the actual M Engine that you might never see as an end-user. Let’s take a quick look at the onion that is Power Query:
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			The layers behind Power Query

			There are a total of three possible layers in Power Query, but some product integrations might only have the first two layers. These layers are:

			M Engine - The underlying query execution engine that runs queries expressed in the Power Query formula language (“M”).

			M Query - A set of commands written in the Power Query M formula language. 

			Power Query User Interface – Also known as the Power Query Editor, serves as a graphical user interface that helps the user with actions such as but not limited to:

			
					Creating or modifying M queries by simply interacting with the user interface

					Visualizing queries and their results

					Managing queries by creating query groups, adding metadata, etc…

			

			At the bare minimum, a product integration might have at least the M engine and the M query components. But as you can see from the table below, not every integration will contain all three layers of the Power Query onion:
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			Not all Power Query integrations contain all of its components

			Experiences by Product Integration

			If during the first half of 2021 you tried to compare the experiences found in Power Query for Excel against the Power Query experience found in Power BI Dataflows, you might have noticed some differences. Power BI Dataflows leverages the Power Query Online user interface, where Excel and Power BI have an experience based on the Power Query Desktop user interface. While the user interfaces do have differences, the underlying process of using them is similar.

			If you try doing this again in the first quarter of the year 2024, you might notice that the gap is not as big as it was before. That’s primarily because the Power Query team is trying to work towards a single and unified core experience for the Power Query User Interface which will then be used across all user experiences and products.

			Of course, there might still be some unique features per product integration in the future. Things such as grabbing data in a table directly from an active workbook might still be something unique to the Power Query experience found in Excel, but the core of the experience will be quite similar across all product integrations. Some of these differences translate into differences in the M engine, M code and the Power Query User Interface layers, while others might only impact something like the user interface. (An example might be different icons between different experiences.)

			One thing which is certain is that, currently and for the past few years, Microsoft has been making a huge investment to push things to the Power Query Online experience first. Once they’ve iterated and tested enough, they then move those features into preview in the Power Query Desktop experiences, followed by eventual general release. This means that if you ever want to try out the “latest and the greatest” from Power Query, your best option is to use the Power Query Online experience through any of its product integrations such as Power BI Dataflows.

			It is no secret that this tool is evolving quickly, both in features as well as user interface changes. Due to this fact, we have concluded that writing a book about Power Query with screenshots of the user interface that will remain current for the rest of our lives is simply impossible; in fact, the release of this book was delayed for two years while we waited for one user interface change to become live in Excel.

			While we provide a great deal of click-steps through this book, we need you to recognize that the actual steps that you need to take when this book is in your hands may differ – both by product integration as well as by product if the user interface gets an update. But what won’t change is the goal, theory or recipes behind the examples. That is the core we are attempting to teach here; how to master your data, not necessarily the specific user interface you’ve been presented with. In this way, we hope to achieve our mission of writing a book that can be relevant for several years to come.

			The Power Query Update Cycle

			Before we tell you where to get Power Query, let’s talk about the updates. Yes, that may seem like putting the cart before the horse, but there is a pretty solid reason for this.

			The Power Query team releases monthly updates. We’re not talking bug fixes (although those are certainly included); we’re talking new features and performance enhancements. While some are small, others are much larger. In early 2015 they released an update that cut query load time by 30%. In July 2015 they released one that solved some very serious issues with refreshing to Power Pivot. We’ve seen Join Types, Conditional Columns and so much more released over the ensuing years. In the last three years specifically we saw the introduction of Columns from Example and Fuzzy Matching, among other new features.

			So how do you get your hands on them? The answer is, it depends on the end point where you are consuming Power Query.

			Power Query Online

			Power Query Online refers to any instance of Power Query used in an online experience in programs such as Power Automate, Power BI Dataflows and others. These are all web-based services and there is nothing you need to update in any of them. Fixes and features are released on an ongoing basis, so you just need to review them every now and then to see what’s been added.

			Microsoft 365

			Our preferred way to consume Excel (or any other Office product) is via an Microsoft 365 subscription. If you are on subscription, the software will just update automatically with new bug fixes and features on a regular basis based on the “Channel” that your version of office is using.

			🍌 Learn more about Channels at the following link:
https://docs.microsoft.com/en-us/deployoffice/overview-of-update-channels-for-office-365-proplus 

			Excel 2016/2019/2021

			Power Query is a product under constant development. If we look back at Excel 2016 (originally released in Sep 2015), it finally brought Power Query into Excel natively, but it also shipped with a named range bug as well as a legacy experience for combining files. In addition, the Join Types, Conditional Columns and Column From Examples feature hadn’t even been released at that point.

			The good news is that even though the Excel 2016 and 2019 products were never on subscription, they did receive some Power Query updates after their initial releases. And we highly recommend that you update your software to get the new experience that we illustrate in the book.

			The secret to getting these deployed on your system is to ensure that your system also gets updates for “other Microsoft products” when it downloads its Windows Updates. To check this setting in Windows 10:

			
					Press the Windows key and type Windows

					Select the Windows Update Settings

					Go to Advanced Options

					Check the box next to “Give me updates for other Microsoft products when I update Windows”

			

			Excel 2010 & 2013

			Unlike Excel 2016 and higher, where it is built-in as part of the product, Power Query must be manually downloaded and installed from https://go.microsoft.com/fwlink/?LinkId=317450. The final update for Excel 2010 & 2013 was released in March 2019.

			Power BI Desktop

			Power BI Desktop has two delivery mechanisms. If you installed it via the Microsoft Store, then it will continue to update for you automatically. If, on the other hand, you downloaded and installed it via the advanced options at https://powerbi.microsoft.com/en-us/downloads/, you’ll have to manually download and install updates.

			🍌 The cool thing about Power BI is that this is the first place we see new Power Query releases. They’re usually hidden in Power BI’s options window under the Preview Features tab. But if you want to see what’s coming to Excel, check there. New features are typically released to Power BI Desktop first, and then come to Excel 2-3 months after they hit General Availability (they are no longer in preview) in Power BI Desktop.

			How to Use This Book

			This book is intended to be your #1 resource in order to understand Power Query and the M language from a practical point of view, no matter if you are new to the tool or a seasoned ETL pro. Our goal is to address common problems that affect the everyday user and show you how we can use Power Query to solve them. We’ll also cover some more advanced scenarios as well, incorporating Power Query and M best practices throughout, to help you understand not only how to build Power Query solutions, but how to make them last.

			The vast majority of the scenarios, illustrations and cases used through the book will be shown using the Microsoft 365 version of Excel. Unless otherwise stated, the illustrated scenario will work in either Excel or Power BI.

			Where to Find the Power Query Commands

			The key to locating the Power Query commands is simply to know where to look:

			Excel 365

			In versions of Excel released as part of a Microsoft 365 product, (which we refer to as Excel 365), the Power Query commands are found on the Get & Transform group of the Data tab. While there are some one-click shortcuts to common sources, you can find all the Power Query data sources available to you under the Get Data button.
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			Locating Power Query in Excel

			Power BI Desktop

			In this software, you don’t even have to leave the Home tab. Notice the huge Get Data button that is right there waiting for you to click it.
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			Locating Power Query in Power BI Desktop

			Previous Excel Versions

			While this book focuses on the Microsoft 365 version of Excel, the majority of the features are compatible with earlier versions. The thing to recognize however is that the commands may be in different areas:

			
					Excel 2019:  For the most part, Excel 2019 will look very similar to Excel 365. The one big exception at the time of printing was that the “From Sheet” button you will be directed to and see pictured in this book was called “From Table/Range”.

					Excel 2016:  Like in Office 2019/365, the Power Query entry point is found on the Data tab, however you’ll find them under the New Query button (in the middle of the Data tab) instead of under the Get Data button you’ll find pictured throughout this book.

					Excel 2010/2013:  You’ll find Power Query on its own tab once you have downloaded the installer. Where the steps in the book will point you to go to the Get Data button on the Data tab, you’d need to go to the Power Query tab and locate the command there.

			

			“Get Data” Click-Steps

			Power Query can connect to a wide variety of data sources, which you can explore by clicking the Get Data button found on the Data tab in Excel, or the Home tab in Power BI Desktop. While Excel’s data sources are subcategorized in menu subfolders, you’ll find that in order to see the subcategorized list in Power BI Desktop, you’ll need to click the More… button.

			For the sake of consistency, we will use the following method to describe how to connect to a CSV file:

			
					Create a new query →From File → From Text/CSV

			

			The actual Excel click path would be:

			
					Go to the Data tab → Get Data → From File → From Text/CSV

			

			This would be equivalent to the following in Power BI Desktop:

			
					Go to the Home tab → Get Data → More… → File → Text/CSV

			

			If you are still using Excel 2016 or earlier, these click-steps would read as follows:

			
					Excel 2016:  Go to the Data tab → New Query → From File → From Text/CSV

					Excel 2010/2013:  Go to the Power Query tab → From File → From Text/CSV

			

			Special Elements

			🍌 Notes will appear in an indented paragraph with a banana icon. These delicious paragraphs point out special features, quirks, or software tricks that will help increase your productivity with Power Query.

			🙈 Warnings appear in a shaded paragraph with a "see-no-evil monkey" icon. Ignore these at your peril, as they call out potential pitfalls and problems that could cause queries to break in the future.

			Example Files

			Before reading further, we highly recommend you download all the Workbooks used in this book so you can follow along with us. You can get them all at the following webpage:

			https://skw-t.com/myd-files

			It’s time to explore this amazing tool in-depth. Let’s get started.

		

	
		
			Chapter 1 - Power Query Fundamentals

			The purpose of Power Query is to collect and reshape data into the desired format, before loading it into tables for consumption by the business analyst. The basic overview of the process, which Power Query will attempt to follow without your intervention, can be visualized as follows:
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			An overview of the Power Query process

			Of course, we can manipulate any part of this process at any time. And indeed, in this book we will do a lot of that. But to begin with it is helpful to walk through and understand the overall method that Power Query is attempting to follow.

			Before You Begin

			Before you launch into your Power Query journey, there are some defaults that we suggest you change in the Power Query interface. Why? Microsoft turned certain features off to avoid overwhelming you, but unfortunately some of these items are critical in order to use the tool properly. And since you have this book, you’ll be guided through the correct use here anyway!

			Adjusting Excel’s Default Power Query Properties

			To adjust your default settings in Excel:

			
					Go the Data tab → Get Data → Query Options

					Under Global → Data Load, ensure that Fast Data Load is checked. (This setting will lock Excel’s user interface during a refresh but will ensure that you have up to date data before continuing.)

					Under Global → Power Query Editor, ensure that every box here is checked. We especially want to make sure the Formula Bar is showing but checking every box will make sure you have all the options that you’ll see throughout this book.

					Click OK

			

			There are other options within this area, but for now the default settings will work just fine.

			Adjusting Power BI’s Default Power Query Properties

			To adjust your default settings in Power BI Desktop:

			
					Go the File tab → Options & settings → Options

					Under Global → Power Query Editor, ensure that every box here is checked. We especially want to make sure the Formula Bar is showing but checking every box will make sure you have all the options that you’ll see throughout this book.

					Click OK

			

			🍌 While in the Power BI Desktop options, you may also want to check the Global → Preview Features tab to see if any new features look enticing. As features are released to Power BI Desktop first, this is a great place to see what is coming to Power Query in Excel.

			Extract

			In this chapter, we will look at importing a simple CSV file into Power Query in Excel or Power BI to show just how Power Query approaches the tasks above, how they look in the user interface, and how they are identical between the two programs.

			The ETL process all begins with the Extract step. Inside this step are four distinct subtasks as follows:
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			The four sub-steps of the Extract process

			Configure Connector Settings (Choose Your Data)

			The first step is to choose and configure the data connector we want to work with. In this case, we’ll start by creating a new query that uses the CSV connector in Excel:

			
					Go to Get Data → From File → From Text/CSV

			

			This would be equivalent to the following in Power BI Desktop:

			
					Go to Get Data → More… → File → Text/CSV
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			Connecting to a Text/CSV file in Excel (left) or Power BI Desktop (right)

			It is worth recognizing that you could attach to a Text/CSV file in less clicks in either program. As Text/CSV files are a common data source, they surface in the user interface much more quickly than drilling down into the sub-menus. In Excel you’ll find this connector right beside the Get Data button on the Data tab. And in Power BI the connector is on the very first level of the menu, with no need to drill down into the More… sources. This, however, won’t always be the case as we move into other data sources later in the book, so we’ve standardized on the full path to the data source.

			🍌 Power BI Desktop can actually connect to a larger set of data sources than Excel. The intention of the team here is to release beta connectors into Power BI and – once they have passed beta stage – eventually bring them to Excel.

			Once we’ve selected the connector we wish to use, we’ll be able to browse to and locate the file. In this case, we’ll connect to the following sample file:

			Ch01 Examples\Basic Import.csv

			Authentication

			Many data sources will require authentication before you’ll be allowed to connect to them. Should that be the case, you’ll be prompted to provide authentication at this stage. Fortunately, this is a CSV file stored in your local file system and the mere fact that you have access to it implies authentication.

			The Preview Window

			Once you’ve selected your file, you’ll be taken to a window that looks similar to the following:
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			The Preview window for Power Query

			The purpose of this window is to present you a view of the data as Power Query will interpret it, allowing you to make any necessary changes before Power Query starts the transformation process. Overall, we find that you rarely need to change anything here, as Power Query is fairly good about making the correct default choices in most cases. Having said that, you’ll notice that there are options at the top which will allow you to toggle the settings for:

			
					File Origin. This would allow you to change the file encoding standard. It is unlikely that you will ever need to change this setting.

					Delimiter. It is also quite rare that this needs to be changed, as Power Query usually gets this right. If required, however, you could manually set this to one of a variety of options including a list of common characters, custom characters or even fixed column widths.

					Data Type Detection. This selection allows you to tell Power Query to detect data types based on the first 200 rows, entire data set or not at all.

			

			Another important thing to be aware of is the message about the data preview being truncated. This is super important to be aware of as there is a limit to how much data can be shown in this window.

			Choosing the Query Destination

			At the end of the day, it’s unlikely you will change anything in this preview. The main purpose of the preview window is really to give you a look at the state and shape of the data and allow you to decide if this data meets one of three criteria:

			1.Is it the wrong data set? If so, click the Cancel button.

			2.Is it perfect? Then click Load.

			3.Does it need reshaping or enriching? Then click Transform Data.

			🍌 It is our belief that 80%-90% of data needs some kind of transformation before it can be used. The degree of transformation may be simple (just renaming a column), or much more complex. Regardless of what is required, however, the default option here should not be “Load”, but rather “Transform Data”.

			Now that we’ve had a preview and decided that this is the data we need, we’ll click the Transform Data button to launch Power Query, which will launch you into a new window as shown here:
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			The Power Query Editor window in Excel

			Transform

			The next step of the ETL process is to Transform your data. Unlike Excel’s classic methods for importing data however, Power Query allows you to see and modify the default transformations that the system has assumed for you in the ETL process. These are managed in the Power Query Editor window, which launched upon clicking the Transform Data button.

			The Query Editor Window

			There are seven main areas of the Power Query Editor that we will be referring to within this book, each of which are numbered in the image shown here:
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			A detailed look at the Power Query Editor

			The terms for each of these areas are:

			1.The Ribbon: Located at the top of the screen, the Power Query ribbon has four tabs: Home, Transform, Add Column and View.

			2.The Query Navigator Pane: In versions of Excel prior to 365 this pane was collapsed by default. You can always click the > just above the word Queries in order to maximize it, showing a list of all Power Queries in the project. (Note that in Excel 365 and Power BI, this window is expanded by default, and can be collapsed by clicking the < button instead.)

			3.The Formula Bar: If this area is not showing, it means that you didn’t follow our advice earlier in the chapter on setting your defaults correctly. As this is an essential tool, it’s a good idea to hop over to the View tab on the Power Query Ribbon and check the “Formula Bar” checkbox now.

			4.The Current View Window: This area is your working area to execute and preview data transformations. But while it can display a data preview, it may also allow viewing a schema view or diagram view.

			5.The Status Bar: Located at the bottom of the screen, this provides a quick summary of the column count, row count and indicator of how many rows are being used to drive column profiling statistics, as well as an indicator on the far right as to when the preview was last updated.

			6.The Properties Window: This area provides the name of the query and is inherited from the query’s data source.

			7.The Applied Steps Window: This area will become very important to you in your Power Query journey, as it shows the transformations that have been applied to your data preview, and that will be applied to the entire data set upon import.

			Default Transformations

			Upon first extracting data from a file, it is helpful to understand what Power Query has already done for you. To do this, we’ll focus on the steps that are listed in the Applied Steps window on the right side. You’ll notice that there are currently three steps listed:

			1.Source

			2.Promoted Headers

			3.Changed Type

			The key thing to be aware of is that each of these steps is selectable, so you can see exactly what Power Query did when it imported the file. Let’s look at each one:

			Source

			By default, the first step of every query will be called “Source”, no matter what data source it comes from. Selecting it in the Applied Steps window will change the preview to show you Power Query’s original interpretation of the raw data it extracted:
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			The visual representation of the Source step

			At this stage of the ETL process, Power Query has identified each comma in the original data set should be used as a column separator, and it has done so. But no further transformations have been made.

			At this point Power Query’s internal algorithms determine something about this data: Row 1 looks different than the next few rows… it looks like a header.

			Promoted Headers

			When you click on the Promoted Headers step, you’ll see the effect of Power Query’s assumption. It uses the values from row 1 as column headers, replacing the generic Column1, Column2, etc… headers that were there previously:
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			The results of the “Promoted Headers” step

			Changed Type

			The final step in the current query is called “Changed Type”, and it looks as shown here:
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			Column headers showing the results of the “Changed Type” step

			The logic behind this step is that Power Query has scanned the first 200 values in each column and made a judgement as to what types of data the columns hold. It then adds this step to “lock in” those data types prior to loading the data to a destination. The most common data types you’ll see are:

			
					DateTime (indicated with a calendar/clock icon),

					Whole number (indicated with a 123 icon),

					Decimal number (indicated with a 1.2 icon), and

					Text (indicated with an ABC icon).

			

			🍌 There are actually many more data types available in Power Query, but we will discuss these in more detail in future chapters.

			Making and Modifying Transformations

			So far, Power Query has been super helpful, and appears to have done everything correctly. But what if we wanted to make some more changes to our data?

			Let’s start by removing a column that we don’t need: the “POS Hour” column. (We’re never going to analyze data in this data set at that level.) To do this you have two choices:

			1.Select the POS Hour column, right-click it and choose Remove, or

			2.Select the POS Hour column and press the DEL key on your keyboard

			Notice that whichever choice you made, the column goes away, and we get a new step called “Removed Columns” showing up in our Applied Steps window:
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			The “Removed Columns” step has removed the “POS Hour” column

			But wait… what if we needed that column after all? No problem, we could just delete the step! We’re not going to do this now, but if you wanted to, you would go to the Applied Steps window and click the X to the left of the Removed Columns step. The step would disappear immediately, and all the data from that column would be visible again. You can basically view this as an “Undo” feature with Power Query, only better. Unlike the Undo feature, which loses its memory when you close the application, this Undo stack persists until you modify it!

			🍌 While being able to Undo a step is very important, there is an even bigger implication of this feature… it gives you license to click anything at any time, just to see what it does. Power Query is always working on a copy of your data, so it is impossible to compromise your data source. This gives you the ultimate ability to look at any button and answer the question “I wonder what that does?” Just click it, and if you don’t like the outcome, simply delete the step. We encourage you to do this with any command you don’t recognize. Not only will you discover new functionality, you’ll start to learn how to match the descriptions in the Applied Steps with the feature that generated them!

			Now, getting back to modifying our data… how about we simplify our column names, starting with Item Name:

			
					Right-click the Item Name column → Rename → Item

			

			A new step called “Renamed Columns” will appear in the Applied Steps window, and you’ll have uncovered a trend: each time an action is performed in Power Query, a new step is added to the Applied Steps window.

			The implications of this are rather important. Unlike the classic Excel world, where data can be transformed with absolutely no trail at all, Power Query gives a full audit trail of transformations. By default, each step you take through the user interface will be added to this window. While you may not know where the command is that drove this transformation, you can at least see what type of transformation took place and – if you select the previous step – you can even see what the state of the data looked like before the transformation was applied. (Then simply select the later step to see the effect of the transformation.)

			Now, what will happen if we decide to rename another column? Will we get a new step again? Let’s find out. Just as there are multiple ways to do things in Excel, there are multiple ways to do things in Power Query. To rename our column this time, take the following actions:

			
					Double click the Units Sold column header

					Change the text to “Units”

			

			Notice how the change takes place, but this time we do NOT get a new step. We still only have one step called “Renamed Columns”:
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			The two rename actions have been combined into a single “Renamed Columns” step

			Be aware that whether you right-click and rename the column or double click it, the result here would have been the same. When performing two “like” actions in sequence, Power Query will consolidate them into one step. The reason for this is simple: it keeps the steps list shorter and easier to read. As many files require significant data cleanup, this can be a real blessing.

			🍌 Naturally, there can be a flip side to this feature as well. Let’s say that you renamed six columns, then realized that you accidentally renamed the wrong column. While you could delete the step, that would remove the entire step, including the five rename actions that were correct. Alternately, you could rename the column back to its original name, or – as you’ll learn later in this book – edit the M code formula.

			Load

			At this point, we have a query which has performed the following actions:

			
					Connected to the CSV data source

					Promoted the first row to headers and set data types

					Removed an irrelevant column

					Renamed two columns to make them more friendly

			

			For this data set, that’s enough. The data is in a clean tabular format, and it is ready to be used to drive business intelligence. It is time to finalize the query and do exactly that.

			Set Data Types

			Before finalizing your queries, it is a very good idea to re-define the data types for each column in the data set. The reasons for this will be discussed in a later chapter, but we want you to set good habits right from the beginning of your Power Query journey. In fact, so does Microsoft, and that is the reason that Power Query adds data types by default as the last step of each query.

			While you can click the icon in the top left of each column to choose the appropriate data type, this can take a fair amount of time, especially if you have a ton of columns to deal with. Another trick is to let Power Query set the data types for all columns, then override the ones you want to change. To do this:

			
					Select any column

					Press CTRL + A (to select all the columns)

					Go to the Transform tab and click Detect Data Type

			

			This will result in a new Changed Type step called “Changed Type1” being added to the query as shown here:
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			Visualizing the results of (re) setting the column data types

			Why “Changed Type1”? The answer is that the query already has a Changed Type earlier in the steps list (the step that Power Query automatically added after the initial promoting of headers). This step helps underscore a few more important things to understand about how Power Query works:

			1.Each step name in the query must be unique,

			2.The Power Query engine will increment a number at the end of any step name that already exists, and

			3.While performing two “like” actions in succession results in the steps being combined (as we saw with the Renamed Columns step), similar actions will not be combined into a single step if there is a different step between them.

			Are we stuck with that step name? Not at all. While we generally encourage leaving the steps as is, and learning which user interface commands generate those steps, you are absolutely able to rename them if you’d like to:

			
					Right-click the Changed Type1 step → rename

					Change the name to “Lock in Data Types”

			

			🍌 The only step that cannot be renamed in this way is the Source step. To rename the source step, you need to edit the query’s M code.

			Name Your Query

			By default, a query assumes the name of the data source as the query name. Since “Basic Import” is far from ideal, we’ll change that to something more logical.

			
					Go to the Query Settings Pane → Properties → Name

					Change the name to “Transactions”

			

			The final query now looks as follows:
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			The results of renaming the query and the final query step

			Loading the Query - Excel

			To finalize your query and load the data in Excel, you need to:

			
					Go to the Power Query Home tab

					Click Close & Load

			

			At this point, Power Query will apply the steps you built in your query to not only the data preview you have been working with, but rather the entire data source. Naturally, depending on the size of the data source and the complexity of the query, this could take some time. When complete, you should see your data loaded to a table on a new worksheet:
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			The Transactions query loaded in Excel

			In the image shown here, we have highlighted three individual elements in the Excel user interface:

			1.The Query pane. This will always match the name of the Query as defined inside the Power Query editor. 

			2.The Table name. This will usually match the name of the Query, but illegal characters will be replaced with the _ character, and conflicts with other worksheet names will be resolved by appending a numeric value at the end of the query name.

			3.The Worksheet name. This will usually match the name of the Query, but illegal characters will be replaced with the _ character, long names may get truncated, and conflicts with other existing tables will be resolved by appending a numeric value within parenthesis at the end of the query name.

			🍌 Each of the three elements may be renamed, and do not need to stay in sync with each other in order to continue working.

			Loading the Query – Power BI

			The only real difference between loading a query in Power BI vs Excel is the name of the button:

			
					Go to the Power Query Home tab

					Click Close & Apply

			

			Just like with Excel, Power Query will apply the query steps to the entire data source. The main difference is that – in Power BI – the data will end up loaded into the Power BI data model. Once complete, you’ll see your table show up in the following locations:

			
					The Fields list (on the right side of the Reports pane)

					The Data tab (pictured below)

					The Model tab
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			The Transactions table loaded in Power BI Desktop

			While Excel shows a summary of the total count of rows loaded in the Queries & Connections pane, Power BI does not. Fortunately, you can still see this information when you switch to the Data tab by selecting a table from the Fields list on the right. When you do this, the total count of rows loaded will be shown in the bottom left-hand corner of the page.

			🍌 Unlike Excel, Power BI will sort the data by the first column by default. To replicate this in Excel, you would need to add an explicit step to sort the data before loading.

			Refreshing Queries

			As you learn more about Power Query’s capabilities, you’ll realize that it can be used to clean up data much more efficiently than classic methods we used to employ in Excel. But the real benefits come when you get to take advantage of Power Query’s ability to refresh a query when the source data file is updated. At that point, Power Query will perform each of its steps against the updated data source, landing the updated output to the load destination. And the best part? Making this happen is super easy.

			
					In Excel: Go to Data → Refresh All

					In Power BI: Go to Home → Refresh

			

			After that, all that is left is waiting for Power Query to read the data from the file, process it, and land it to the Excel table or Data Model.

			While Power BI will always show a dialog when data is loading, seeing that a refresh is taking place may not be quite as obvious in Excel. It will show in the status bar (at the very bottom of the Excel interface) but this is very subtle and easy to miss. The most obvious way to watch a refresh process is to make sure the Queries & Connections pane is showing, as the refresh process is displayed on the queries listed here. The figure below shows the queries being refreshed in Excel and Power BI respectively:

			[image: Graphical user interface, application
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			Query load progress displays in Excel (left) and Power BI Desktop (right)

			Once the data has been loaded, Excel will show the total number of rows loaded in this tile, and you can check the Power BI row counts by switching to the Data tab and selecting the table (as described in the previous section).

			This feature works very well for data files that get updated on a regular basis. Whether the source file is an Excel file that multiple people are updating, or a CSV that you extract every month-end, and just save over the prior month’s version, you’re a quick click away from a full refresh.

			Editing Queries

			While the one-click refresh is amazing, we often build solutions that need to be repointed to a different file before refresh. For example, let’s assume that we’ve built a query against a file called Jan.CSV which holds January’s data. Then you receive a new data file called Feb.CSV. Obviously just clicking refresh isn’t going to achieve the desired result, as it will only refresh the January transactions, and not give you the February transactions from the Feb.CSV file. In this case, we need to change the file path before we trigger the refresh, and that means editing our query. And to edit our query, we need to get back into the Power Query editor. The steps to do this depend on the program you are using.

			Launching the Query Editor – Power BI

			Launching the Power Query Editor is super easy in Power BI. All you need to do is go to the Home tab and click on Transform Data. This will open the Power Query editor, allowing you to modify any existing queries (or even create new ones).

			[image: Graphical user interface, application, Word
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			Click the Transform Data button to edit queries in Power BI

			Launching the Query Editor – Excel

			In Excel, there are actually three options for launching the Power Query editor, and two of them rely on the Queries & Connections pane being active. Unfortunately, this pane needs to be opened manually when a new Excel instance is started, and this can trip people up. Since the vast majority of Excel solutions we build today involve Power Query, you’ll find that one of the first steps after opening Excel is to display this pane. You can do that via the following click-path:

			
					Go to the Data tab → Queries & Connections

			

			As far as options for launching the Power Query editor in Excel, these are your choices:

			
					Go to the Data tab → Get Data → Launch Power Query Editor

					Go to the Queries & Connections pane → Right-click any query → Edit

					Go to the Queries & Connections pane → Double click any query

			

			🍌 Since we leave the Queries & Connections pane open most of the time, we typically use the latter two methods. We also joke that the difference is really whether you would like to wear out your mouse buttons evenly or put more stress on the left mouse button.

			Reviewing Steps

			Once you have returned to the Power Query editor, you now have the ability to review any step in the query simply by selecting it in the Applied Steps window. As you select each step, the data preview will refresh to show you the effect of the given step.

			🍌 Data previews do take advantage of caching. If you ever notice that the data is out of date, or if you want to ensure that it isn’t, you should force a refresh of the previews. To do this, click the Refresh Preview button on the Power Query Home tab.

			[image: Graphical user interface, application
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			The Refresh Preview button can be found on Power Query’s Home tab

			Reconfiguring Steps

			As you have returned to the editor, you now have the full ability to add new steps, delete steps, and even modify steps within the query. In the case of this example, what we’d like to do is reconfigure the query to point to a new data file.

			🙈 If you open the completed Excel or Power BI example files for this chapter, you’ll notice that they will fail to refresh. The reason for this is that the Source step is pointed to the path of where the data file lives on our system. Following the steps in this section will allow you to repoint the solution to use the correct data file.

			Let’s look at the current query steps:

			[image: Graphical user interface, text, application
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			The current steps of the Transactions query

			In this image we can see something very important… two of these steps have a little gear icon to the right side of the step name. This gear icon allows you to reconfigure a given step using a user interface.

			🍌 As a general rule of thumb, if you are prompted with a dialog when you perform an action in Power Query, you will get a gear icon which will allow you to reconfigure the step. (If you don’t get prompted with a dialog, it’s likely you won’t see the gear icon.) There are exceptions for every rule, of course, as you can see in the case of the Promoted Headers step.

			In looking at the query, we know that the original data source must be referenced at the very beginning of the query, and fortunately, the Source step has one of those gear icons!

			
					Select the Source step

					Click the gear icon

			

			You’ll be taken to a new dialog which will allow you to reconfigure key components of this step:
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			Reconfiguring the Source step

			The very first field in this list is the File Path, which just happens be the field we want to update. So let’s do exactly that:

			
					Click Browse

					Locate the following sample file:Ch01 Examples\New Data.csv


			

			🍌 Power Query did a pretty good job of configuring the correct choices for us when we first imported the data, so there is nothing else we need to change here. But what if it had picked the wrong delimiter (say Comma instead of Tab). Notice the Delimiter field at the end? You could change that choice here if you needed to!

			
					Click OK to close the dialog

			

			If the data is significantly different, you’ll see it right away in the preview window. But in this file things look identical. So how can we tell if the change was effective? To further complicate this question, the data set has more than the 999 rows that fit in the data preview window. So… what do we do?

			We load the data!

			🍌 While you can certainly select each step in the Applied Steps window to verify that things still work, there is no requirement to do so here. Since this data has an identical structure to the previous file, each of the steps will be applied without issue. There is no need to select them to make that happen.

			
					On the Home tab, click Close & Load (Excel) or Close & Apply (Power BI)

			

			The data will load, and you can then verify the effect via the Excel Queries & Connections pane (or the row count on the Data tab in Power BI):
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			Our data has changed from 4,575 rows to 4,921 rows loaded

			The Impact of Power Query

			Once you embrace Power Query, you’ll find that it will have a huge impact on your workflow. Some of the key things to remember about this amazing technology are:

			
					It can connect to a wide variety of data sources

					It records each action you take, building up a Power Query “Script”

					It never changes the source data, allowing you to try different commands, and delete the generated steps if you don’t like/need them

					It can be refreshed in future when the data changes

			

			The impacts here are huge. Consider a solution where you have built a Power Query script to perform some significant data cleanup, landing the results into a table on an Excel worksheet. You’ve then created a bunch of charts and reports based on that data table. In the past, when you received an updated data file, you would need to re-do all of the data cleanup steps manually, then copy and paste the clean data into the data table.

			With Power Query, all that re-work is gone; you just click the Refresh All button and you are done. It is just that simple. Not only is it faster but the process is guaranteed to be applied consistently each and every time, removing the human factor that can cause errors.

			Even if you don’t need to take advantage of the refresh capabilities, you’ll find that Power Query gives you a wide variety of tools to make your data cleanup easier and faster. As you’ll learn throughout this book, historically complex data cleanup tasks can now be performed with ease, allowing you to get to the task you’re actually being paid to do: analyzing the data.

			The final thing you want to recognize here is that you aren’t learning one ETL tool for Excel or a (different) ETL tool for Power BI. The Power Query toolset exists in Excel, Power BI Desktop, Power BI Dataflows, Power Automate and other Microsoft products and services… so far. Microsoft has been quite clear to us that they see this as a growth area and have goals on seeing Power Query in many more places. While learning how to use a new tool is always a journey, isn’t it better if that tool can be used in many places?

		

	
		
			Chapter 2 - Query Management

			Before we dive into the incredibly vast world of Power Query data transformations, it is a good idea to make sure that you set yourself up for success in future. One of the things we know about solutions is that most start small and end up growing and getting more complicated over time. The methods outlined in this chapter will help ensure that you can set up or manage your queries as the size and complexity of your solution grows.

			Using a Multi-Query Architecture 

			As you’ve learned in the Introduction and Fundamentals chapters, Power Query is a program that provides you with ETL functionality for your solutions. As shown in Chapter 1, Power Query actually works through this entire process in each query that it creates. The only challenge? This doesn’t necessarily set you up well for maintenance or when your solution scales in size. For this reason, you may wish to add some additional query layers to the solutions you build.

			Separate Queries for E, T & L

			Rather than performing all of your query steps in a single query, we can also break the tasks down into multiple queries. For example, consider the following structure:

			
					Raw Data: This query is used to Extract the data from the data source. Very little transformation is done here. In fact, we typically only remove unusable columns or rows in this step. The end goal is a clean table of ALL records in the data set, whether you plan to use them or not. This gives you a single place to view (and change) the original data source, and see what records are available to you.

					Staging: The purpose of a staging query is to handle the majority of the Transform portion of the ETL process. In these queries we reduce the data, and make whatever cleanup or transformations are needed in order to create clean tables for later use. While the staging layer should consist of one query at a minimum, it is entirely acceptable to break it down into multiple queries, should you be able to or need to do so.

					Data Model: You can view these queries as the final step before the Load stage in the ETL process. These queries always assume the name of the table you wish to create in an Excel worksheet or the Data Model, and their main function is to perform any final steps before loading. Typically, these will include appending and/or merging staging queries together (if required), as well as setting the final data types for each column in the table.

			

			At first glance, this might seem like overkill. Do you really need three separate queries to collect, manipulate and load data for a single Excel table? As it turns out, Ken and Miguel have differing opinions on this…

			The Benefits of a Single Query

			Miguel prefers to build all steps in a single query or in the least number of queries possible. This is following the same minification concept that is used in other programming languages where you try to optimize your code and its outcome by stripping out any unnecessary pieces inside your solution, keeping things as tidy as possible. Here are some of the benefits from this method:

			
					It is very easy to find the query you need when there are only a few in your queries list. As the Query Navigator doesn’t have a search feature, a huge list can make it difficult to locate the specific query you are after.

					The more queries you have, the harder it is to trace the lineage of them, as Power Query doesn’t have a great toolset to do this.

					There are times where splitting queries can trigger a “Formula Firewall” error. This can be super frustrating and there are some instances where you must declare all your data sources in a single query to get past this.

					Other programs that make use of Power Query – such as SSIS and Azure Data Factory – only support a single query. If your goal is to port your solution to one of those platforms, it is a better idea to stick to a single query.

					You always have the benefit of seeing how everything ties together in a single view and make fundamental changes to your query so that the transformation process can be in its most optimal form. This is incredibly beneficial when you are using the Query Diagnostics tools and checking for more advanced things such as Query Folding and checking the Query plans.

			

			The Benefits of Separating Your Queries

			Ken prefers using separate queries and argues that there are several benefits to structuring your queries as described above. While this is not an exhaustive list, here are just a few of the benefits:

			
					It is very easy to select your Raw Data query, see what data is available to you from the data source, and to update that query if the data source changes.

					You can re-use prior queries (from Raw Data to Staging) multiple times, saving you from having to duplicate work.

					Maintenance of your solution becomes easier when the file path to your data source changes, as you only have one file path to update in your solution, no matter how many times you’ve used it.

					Updating to a new data source type is also much easier, as you can create a new Raw Data connection in parallel with the old source, make sure the columns are named the same, and then just swap it in place of the original connection.

					While there are instances that required keeping your data sources in one query to avoid the Formula Firewall, there are also instances where you must separate your queries to bypass it.

			

			Again, Ken feels there are many more benefits to this setup. And when you move into using Power Query to serve up the data for a dimensional model in Power Pivot or Power BI, you’ll love how easy this setup makes it to build good Fact and Dimension tables. It’s for this very reason that the Dimensional Modeling course at https://skillwave.training begins by covering this very topic!

			🍌 One of the great benefits of Power Query and Power Pivot is the ability to rapidly prototype Business Intelligence solutions without having to get IT involved. Even if you start from an Excel table as a data source, why not set up the solution so that you can easily repoint a query to a SQL database table when the time comes?

			Does Separating Queries Impact Performance?

			One concern you may have about separating your queries relates to performance. Will this kind of a setup slow down the refresh in any way?

			In both Power BI and Excel 2019 and higher (including Microsoft 365), the answer is no. These versions of Power Query take advantage of a technology called “Node caching”, which caches the results of the first refresh in a sequence, then re-uses it for other queries in the same refresh session. 

			Assume for a moment that we have a query setup which retrieves data from a CSV as shown here:

			[image: Diagram  Description automatically generated]

			A simple query chain where the results of the Staging query are re-used

			Assume also that very little happens in the Raw Data query, but that there is a complex multi-step set of transformations required to get the Staging query into a clean format. From there, the Sales and Clients queries are both quite short, simply pulling their data from the Staging query, then removing the columns and rows that are not relevant for their outputs.

			When refreshed, the Staging query will be generated once and cached. The Sales query will reference that cache, perform any additional transformations required, and load that data to the end destination. Next, the Clients query will then go back and reference the cached version of the Staging query, apply any of its own transformations, then load the Clients table to its destination. The key thing to recognize here is that the Staging query results only get generated once, as it is used by multiple queries.

			Now, compare that with the setup shown here for the same data source:

			[image: Shape  Description automatically generated]

			Separate query chains despite calling from the same data source

			In this case, when Sales is loaded, it must call the data from the CSV, perform the complex transformations in the Staging query, then finish the steps in the Sales query before being loaded.

			Next comes Clients which, as it is completely independent of the Sales query chain, executes the same workflow. Not only must Power Query call the same data from the CSV file, but it also must process all of the steps of the Staging query before it can process and load the results of the Clients query.

			As you can see, referencing queries and re-using them can actually help performance, rather than hinder it.

			🙈 Caution! In the above scenarios, it is important to recognize that the Raw Data and Staging queries should be set up as staging queries. If these queries are loaded to a table or the data model, then you will have created “linked entities”, which will take longer to process.

			Referencing Queries

			So how would you set up queries to follow this pattern? Let’s walk through that process by re-creating the query from the previous chapter.

			Creating the Base Query

			Begin by opening a new Excel workbook or Power BI file. Then:

			
					Create a new query → From Text/CSV

					Browse to and select \Ch01 Examples\Basic Import.csv

					Click Transform Data to enter the Power Query Editor

					Rename the query to “Raw Data” via the Query Settings pane

			

			At this point, your query should look similar to that shown here:

			[image: Graphical user interface, application  Description automatically generated]

			Power Query’s first impression of the Basic Import.csv file

			Have you ever built a solution, only to have your boss ask you to expand it a few months later? Are you left wondering if your data set even contains the data they want you to report on? That is one of the goals of this query: a one stop preview of the data available to you.

			As it happens, the default set of steps that were recorded when we connected to this data set get us to that point. We have a clean table that shows all of the columns in the data set, and all the rows that fit in the data preview.

			🍌 Remember that each data source needs to be reviewed on a case-by-case basis when setting up your Raw Data query. There will be times that you can just accept the initial query from Power Query, but there will also be times that you’ll need to remove the Changed Type step, filter out data, or even expand columns. These will become more apparent as you work through the book.

			Referencing Queries

			With the initial Raw Data query set up, it is now time to reference it and create our first Staging query. To do this you will need to have the Query Navigator pane expanded. This is easy in Power BI, as this is the default state, but in Excel this pane always starts off collapsed. To do this:

			
					Make sure the Queries pane is expanded (click the > above the word Queries if needed)

			

			[image: Graphical user interface, application  Description automatically generated]

			Expanding the Query Navigator in Excel

			With the Query Navigator expanded, we can now see all the queries in the solution, and do the work we need to do:

			
					Right-click the Raw Data query → Reference

			

			This will create a new query called “Raw Data (2)”. We want to rename this as “Staging”, and there are three different options to do so:

			1.Right-click the query in the Query Navigator → Rename

			2.Double click the query name in the Query Navigator

			3.Change the Name in the Properties area of the Query Settings pane

			Each option will result in the query being renamed, so use whichever route you prefer.

			While we’re here, let’s also create that final query that will load our data to the end destination:

			
					Right-click the Staging query in the Query Navigator → Reference

					Rename the new Staging (2) query as “Sales”

			

			Now, let’s take a look at some important elements of what we’ve accomplished so far:

			1.The Query Navigator shows that we now have three queries, of which the currently selected query is “Sales”
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